Support » Plugin: Yoast SEO » Focus Keyphrase Counting Error

  • Resolved kentaiwan98

    (@kentaiwan98)


    Hi! I have a weird focus keyphrase counting problem… I don’t know what is causing it. The problem only occurs on one page, while other even longer pages do not reflect any error. Hope you can help.

    I use the keyword “how to make coffee” in the page, and the page returns an error \

    “Keyphrase density: The focus keyphrase was found 118 times. That’s way more than the recommended maximum of 65 times for a text of this length. Don’t overoptimize!”

    Well, I can honestly tell you, even after checking the HTML, the phrase does not occur more than 18 times, which previously was checked as okay. The error only exists on this one page, which is 3750 words long.

    I’ve tried cutting the phrase out of the text as well which highlights how many times that the keyphrase is in the text. Then I get the answer:

    “Keyphrase density: The focus keyphrase was found 16 times. That’s less than the recommended minimum of 18 times for a text of this length. Focus on your keyphrase!”

    Clearly, there is a bug in program that this page is flagging, but I have no idea why this page triggers the error.

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Support Pcosta88

    (@pcosta88)

    Hi,

    It seems like Yoast is searching for the words “to” and/or “how” as part of the keyword. We would like some more information.

    1. Can you confirm you are using the most recent Yoast SEO, v12.5? If you update, does the issue resolve?

    2.Can you confirm you are using WordPress 5.3? You can check by clicking on the W in the top left and selecting About. If you need to update, please check with your host provider. Please know that if you are using an older version of WordPress Core you may experience unexpected behavior with Yoast. This guide explains more: https://yoast.com/why-we-dont-support-old-wordpress-versions/.

    3. Does the issue resolve if you put quotes around the whole keyphrase?

    Thread Starter kentaiwan98

    (@kentaiwan98)

    Thank you for your reply. I keep everything 100% updated, except when I meet bugs. Currently everything is 100%. I finally nailed the issue. The version of Yoast and WP would be whatever current version was on the day of the ‘bug’ report.

    The word ‘coffee’ was the problem. IOW, Yoast kept flagging that as too often even though the keyword phrase was in fact “how to make coffee”. I recreated the issue in a separate page as well.

    In an article about how to make coffee, you’d expect the word ‘coffee’ to be even more frequent. However, I removed the excess usage of the word ‘coffee’ and that resolved it.

    I can only surmise that the extreme use of the word coffee triggered some other ‘flag’ in your software or that the software was truncating the keyword. I have used much longer KW phrases in the past without issue, though.

    Thread Starter kentaiwan98

    (@kentaiwan98)

    Quick update. Yes, the problem came right back.

    So I added ” ” marks before & after, thus “how to make coffee”.

    So the keyphrase feedback changed from:

    Keyphrase density: The focus keyphrase was found 114 times. That’s more than the recommended maximum of 108 times for a text of this length. Don’t overoptimize!

    to:

    Keyphrase density: The focus keyphrase was found 7 times. That’s less than the recommended minimum of 19 times for a text of this length. Focus on your keyphrase!

    The page is not finished, but I don’t know which to believe! Do I rather remove or add phrases? Puzzled!

    So then I started to check my other longer pages… and I’m seeing the same ambivalence: types of coffee beans

    From
    Keyphrase density: The focus keyphrase was found 15 times. That’s less than the recommended minimum of 17 times for a text of this length. Focus on your keyphrase!

    To

    Keyphrase density: The focus keyphrase was found 15 times. That’s less than the recommended minimum of 27 times for a text of this length. Focus on your keyphrase!

    The only common factor is that each phrase is ‘four words in length’. The only unusual thing is I’m using Site Origin on those pages.

    On other posts, I’m seeing the same behavior when I add quote marks as you suggest. It is a regular occurrence.

    WP 5.3 using SiteOrigin (latest) and Yoast (Version 12.5.1) running on PHP7.2.x

    • This reply was modified 1 year, 11 months ago by .
    • This reply was modified 1 year, 11 months ago by .
    Plugin Support Pcosta88

    (@pcosta88)

    Hi,

    The issue is that you are using function words as part of the keyword. This guide explains more: https://kb.yoast.com/kb/list-of-function-words/.

    When you add those words, it results in that behavior. If you want to resolve the issue you will need to add quotes around the keyphrase. Doing so is not expected to affect the SEO of the site.

    We also understand we need to do a better job of communicating function words to our users. We thank you for suggesting a new feature for one of our plugins. We’re not working on it at the moment but we’ll create a feature request for tossing out a notification when you have function words in your keyphrase and provide some instructions on how to deal with it, so our developers can consider this when planning updates.

    Thread Starter kentaiwan98

    (@kentaiwan98)

    Can’t wait. Those long tail keywords are getting tons of traffic, the shorter ones are pretty much saturated! Thanks:D

    I’m Getting the exact same issue.
    Definitely started happening recently.
    I noticed it so far for the following focus key phrases:
    – contact us
    – lower back pain

    I understand that “contact us” has a function word in it (“us”). However, I don’t see anything like that in “lower back pain”. For that key phrase, Yoast only picks up “pain” as the focus key phrase, which messes with my SEO.

    Just like for kentaiwan98, If I place “” around the focus key phrase it now accepts the whole phrase and….according to the Yoast plugin, it improves my SEO rating.

    Can Support confirm that putting “” around key phrases does NOT effect SEO in a negative way?

    @pcosta88 Any insight?

    Thread Starter kentaiwan98

    (@kentaiwan98)

    Put the ” ” marks around the term in the Focus keyphrase box only, not every instance of the text in your article.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Focus Keyphrase Counting Error’ is closed to new replies.