Support » Plugin: Yoast SEO » flush_rewrite_rules

  • Resolved twohumans

    (@twohumans)


    Hi, in short, when using Pods in conjunction with Yoast SEO we realized that when Yoast is updated we have to reset our permalink not to have a 404 page when trying to access the Pods Custom Post Type Archive Page.
    The back story is that since we are using Pods on several websites spanning over several servers we tried to narrow what could cause that from time to time our Pods CPT Archive Page would return a 404. We realized that Yoast SEO is present on all these sites and that it calls the flush_rewrite_rules() function when upgrading (in file class-upgrade.php) and that it would explain the behaviour that we are seeing in our clients websites. We have eliminated any other common plugins that could have an effect on the permalinks either because the use of flush_rewrite_rules is well defined and used in specific user triggered actions or because they don’t use this function at all.

    Is the flush_rewrite_rules really necessary when upgrading Yoast SEO? Could it be conditional per a user’s request after an upgrade?

    • This topic was modified 1 year, 10 months ago by twohumans.
Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Support Pcosta88

    (@pcosta88)

    Hi,

    We are not able to reproduce this issue. We have WordPress v5.2.2, Pods v2.7.12, theme is 2015 v2.5, and Yoast SEO v11.5. The Pods Custom Post Type Archive Page returned 404.

    We created a Pods Custom Post Type and added one for it with Yoast Active: https://pasteboard.co/Il3GSZm.png

    The Pods post type loaded as expected https://pasteboard.co/Il3GZqd.png

    We went to the archive page and it returned a 404: https://pasteboard.co/Il3H7jB.png

    We then deactivated Yoast so we only had pods active https://pasteboard.co/Il3Hdna.png

    We then went to the archive page again and refreshed it and it showed a 404. We went to Pods Admin-Settings and cleared the cache. Still a 404. We also resaved the permalinks in Settings-Permalinks and a 404 remained: https://pasteboard.co/Il3HDwQ.png

    We would like some more information.

    1. Can you verify all non-Yoast plugins are updated?

    2. Can you confirm you are using the most recent Yoast SEO, v11.5? If you update, does the issue resolve?

    3. If you disable Yoast does the issue still happen? Note, that disabling Yoast briefly will not affect the SEO of the site and all your data will re-appear.

    4. Can you elaborate more on how you are “reset[ting] our permalink”? When you do that, does the Pods Custom Post Type Archive Page show as expected?

    Thread Starter twohumans

    (@twohumans)

    1- They were when we wrote the previous message. We just updated everything again a few minutes ago.
    2- We were using v11.4 – we just updated to v11.5.
    3- As far as we know if Yoast is not activated we are not experiencing this problem.
    4- After an update, we go to Settings, Permalinks and click Save Changes. Yes when we do this the Pods Custom Post Type Archive Page show as expected.

    We did an upgrade this morning and the problem did not reproduce. So it looks like the problem was solved ?
    Note that it looks like this problem was experienced by other users as well.

    Plugin Support Pcosta88

    (@pcosta88)

    Hi,

    We are not sure why the issue is resolved, exactly but we are glad it is. We will mark this issue as resolved. If it happens again you may re-open the issue by responding to it.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘flush_rewrite_rules’ is closed to new replies.