Support » Plugin: WPC Fly Cart for WooCommerce » Floating cart does not get hidden

  • Resolved varrie29


    I have been using your plugin for around 2 weeks and it works great but after the recent update (v2.0.0), the floating cart option called “Hide if empty” does not work anymore.

    My current setting is that the floating cart would only appear on a non-empty cart and should float on the bottom right. Just as this one

    Now when the cart is emptied, instead of the cart being hidden, it instead floats on the left and still visible –

    Kindly advise.


    • This topic was modified 10 months ago by varrie29.
Viewing 6 replies - 1 through 6 (of 6 total)
  • powerfarm


    Hi! The same thing happened to me after I updated the plugin. Hopefully they’ll fix it soon!



    Same here

    Plugin Author WPClever


    Hi @hurikhan , @powerfarm , @varrie29 ,

    Thanks for your reports. I have written a note to our developers and they have quickly released a new update (version 2.0.1) yesterday. Kindly update your site, clear the cache and refresh your site to check it again. I have checked this functionality on our test site, it’s working perfectly.

    Note: the cart on our live demo has this function Hide if empty turned off, so it displays an empty cart with count 0 by default. It’s not an error. Please note that.
    If updating to the latest version doesn’t help, please give us a link of your site then we can do a quick check to find the initial causes.

    Thanks and best regards to you all.

    Hi @wpclever,

    Updated to v2.0.1 and did not solve the “Hide if empty” issue for me. What it at least solved is this one , i.e. the floating cart now remains in the bottom right as in my settings and not float in the bottom left when the cart is empty. But still, it does not get hidden when the cart is empty. The last working version for me was the version before 2.0.0. On the side note, I have not updated to Woocommerce version 4 yet as not all my plugins have released updates for it. Could this be the cause?

    Thank you!

    Hi @varrie29 !

    The upgrade worked for me… Look at deleting the cache of your WordPress, and if this doesn’t work you can also delete the cache of your browser.

    PS: I have already updated Woocommerce to version 4.0.1


    Plugin Author WPClever


    Hi @powerfarm ,

    Thanks for your feedback. Hope you enjoy our plugin.

    Hi @varrie29,
    Yes, indeed. You need to update to the latest version of WooCommerce 4.0.1 and also its database, then clear all the site and browser’s caches as @powerfarm has suggested. It’s necessary to update in order for our plugin to fully function.

    Wish you all the best.

    Best regards.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Floating cart does not get hidden’ is closed to new replies.