WordPress.org

Support

Support » How-To and Troubleshooting » Flickr wont recognise xmlrpc file

Flickr wont recognise xmlrpc file

  • I’ve tried to add my WP blog on flickr, on their site it says to add your url with xmlrpc.php at the end and your blog admin and password. When I do this and click submit flickr just comes back saying my endpoint is wrong?

    Any ideas?

Viewing 15 replies - 1 through 15 (of 33 total)
  • Does xmlrpc.php reside at this “endpoint”? In other words, is the file xmlrpc.php found in your blog directory.

    the xmlrpc file is at:

    http://www.matandkerry.com/xmlrpc.php

    which is the url I entered into Flickr and go the error message.

    I get this message when trying to view your above-posted URL:
    Fatal error: Cannot redeclare wp_insert_post()...

    I’ve fixed that error by downloading and replacing the file with the one in the CVS, had to do a slight edit as its in the same directory as the wp-config file.

    I now get ‘XML-RPC server accepts POST requests only.’ and Flickr stills says ‘not a valid endpoint’

    http://www.matandkerry.com/xmlrpc.php

    I am also having this problem and I’ve also tried installing older versions of xmlrpc to no avail. The “BlogThis” feature worked for me until I installed the latest version of WP.

    Anyone? Help!

    I’m having the same problem here, using 1.5.

    Hate to do a ‘me too’, but yes, my Flickr used to be fine, but after 1.5 I get nothing.

    Solution: I was having this problem (endpoint is wrong and ‘XML-RPC server accepts POST requests only) with WP1.5 Strayhorn. The solution was one of those “forest for the trees kind of things”. I had the file permissions set to “644” on the xmlrpc.php file; when I reset them to 755 it worked.

    Everything worked fine although the Flickr template that was supposed to put a thumbnail and the text on one line ended up not doing that. ( http://www.tom-hanna.org/?p=629 ) That’s probably CSS related and not that big a deal since it still looks ok.

    I feel like celebrating – I solved a problem instead of asking a question for once!

    Update: Flickr told me that the blog posting had failed, but the post is on my blog. Apparently there may be something buggy, but the post actually got posted. If Flickr tells you the post failed, check your blog.

    I tried the permission change, but unfortunately no luck, so since my 1.5 update, I’m still minus Flickr! posts. Ah well.

    You might try setting the permission to 777; the way I understand it (and that is pretty limited) the permissions are affected by who your server defines as “user”, “group” and “other”. At least worth a shot.

    I can’t get it to work with permissions set to 777 either.

    Works fine for me. I’m using 1.5.1, with xmlrpc.php revision 2606. Permissions on the file are set to 644.

    I am seeing the same error on flickr. I downloaded rev 2606 and there has been no change. I also went and tried to install Zempt to see if it would provide a bit more detail. Zempt throws an error:

    “Error! Invalid XML (<methodResponse> not found)”

    Moderator James Huff

    @macmanx

    WordPress v1.5.1.1 has just been released today. Make sure that you are using that version.

Viewing 15 replies - 1 through 15 (of 33 total)
  • The topic ‘Flickr wont recognise xmlrpc file’ is closed to new replies.
Skip to toolbar