• Resolved godvsgodvs

    (@godvsgodvs)


    I hope this post saves someone the hours of time and frustration I’ve been through trying to figure out what was happening. I have a personal Flickr account that I did some initial tests on and then I opened a separate Flickr account dedicated to a community website. All went well testing with my personal account using both the photo view and the photoset/album view.

    Then I switched to the new dedicated Ficker account and there was no way I could get albums to display. The photostream displayed fine. I tried everything, and I mean EVERYTHING. Multiple websites, basic WordPress installs, you name it. I could change just the user_id in the shortcode to the old account and everything was fine. I was beginning to think it was a Flickr problem until I kept thinking, what’s different about the accounts.

    And then it hit me. On the new account I activated a friendly URL and that was the user id shown to me. Turns out in Photonic you have to use the “original” user id that was assigned to you and then everything works as expected. It’s hard to find once you change the URL. Search Google for a utility or in settings use a dveloper tool on your Buddy Icon and you will see it in the URL.

    Hope this helps someone from going through what I did.

    • This topic was modified 4 years, 2 months ago by godvsgodvs.
Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Sayontan Sinha

    (@sayontan)

    Under Photonic → Helpers, there is a section that lets you put your “friendly” id and it tells you what the Flickr id is. Isn’t that what you are looking for? That instruction is provided adjacent to the “User ID” field when you launch the shortcode creator (Add Media → Photonic → Flickr on the edit screen for a post / page), and also on the documentation page for the plugin.

    Thread Starter godvsgodvs

    (@godvsgodvs)

    Oh boy! The Elephant in the room and I didn’t see it. The problem is that the Flickr help tells you to go to your photostream page and look at the url for your ID. They never mention the underlying original ID, at least I didn’t see it. I suppose the confusion started when it worked for the photo view, but not the album view. Weird. If it didn’t work at all, it would have hit me right away. Sorry about that.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Flickr Photsets/Albums-A Quirk’ is closed to new replies.