WordPress.org

Support

Support » Plugins and Hacks » Flickr Gallery – Why doesn’t Lightbox work?

Flickr Gallery – Why doesn’t Lightbox work?

  • I installed the latest version of Flickr Gallery, but the Lightbox feature does not work.. I enable it, doesn’t do anything – When I click on the thumbnails, it just takes me to the Flickr page.. I put a rel=”lightbox” within the code, on the thumbnails, and Lightbox works, but it only shows the thumbnail..

    Any help here is appreciated

    Thanks

Viewing 15 replies - 1 through 15 (of 43 total)
  • I think it’s to do with certain themes. It works on the default template, but not on some others. I’m trying to work it out now!

    You need to make sure that your theme supports the wp_head hook.

    The easiest way to do it is to edit your themes header.php and make sure you put this code in between the header tags:

    <?php wp_head(); >

    Hi ,

    My theme has this but the light box does not work? . I am using buddypress default theme.

    james

    If you’re having this problem, it’s more than likely a conflict with another plug-in you have installed that’s using the jQuery library. Check your headers for any plug-in that loads a jQuery script after the flightbox jQuery and disable that one to see if the lightbox works (it should).

    Unfortunately, I’m not too familiar with how jQuery loads or how to modify the plug-in code to get this to work well with other plug-ins. Maybe the developer can shed some light on this.

    Usually it is a problem with a theme or plugin loading Javascript by manually inserting a <script src=”jquery.js”> type tag into the site which can overwrite the properly enqueued jQuery object that my plugin uses. All themes and plugins need to use wp_enqueue_script() to load Javascript files, but tons of them do not.

    You can find out what is causing your problems by disabling all of your other plugins and re-enabling them one at a time until you find the one that breaks it. If turn off all of your plugins does not fix it, you can try out the default theme to see if your theme is breaking it.

    I had this same problem, I disabled my plugins and lightbox began to work again. Turned out to be the viddler comment plugin I had installed earlier that day. Not sure if there’s a way to work around it.

    I disabled all plugins except Flickr Gallery and activated default theme, lightbox still won’t work for me. Could it be anything else?

    My theme is not working with the gallery plugin installed.
    Do you think is it possible to fix to use both?

    The frontpage is not working when i activated the Gallery plugin.
    You can check the frontpage: http://www.planetahuevo.es

    The plugin is great, but dificult to use. 🙂
    Thanks

    @hybridmovement Could you send me an example? I might be able to spot a problem. http://co.deme.me/contact/

    @darkpollo Which pictures are using my plugin?

    Having same issues with the next button not working, it just gives a blank page, and then the page needs to be reloaded in order to see the first set of images.

    Checked the header, hook is there, no other jquery scripts, tried disabling other javascripts just in case. Still no luck.

    any ideas?

    thanks,
    paul

    correction, i do see a jquery script being loaded from google, but it doesn’t seem to be inherent in either the theme or plugins, for when i use default theme and no plugins, it’s still there in the code.

    thanks,
    paul

    @pnelson7428, I can’t be sure unless you send me a link.

    Also, WordPress does not load the Google versions of jQuery. It distributes its own versions and only uses those. Something would have to be adding the Google-hosted version.

    i setup a quick test page so you can look.

    i do have askimet running to fight spam comments… i haven’t had time to see if that is what is loading the google jquery script. i tried commenting out the extra scripts in the header.php pages with no luck. i also tried the default theme with no plugins (other than askimet). i will try playing with it a bit more later today, but if you see something that jumps out at you as interfering that would be great.

    thanks for the help!
    http://illuminatedvagabond.com/?page_id=853

    -paul

Viewing 15 replies - 1 through 15 (of 43 total)
  • The topic ‘Flickr Gallery – Why doesn’t Lightbox work?’ is closed to new replies.
Skip to toolbar