Support » Plugin: Photonic Gallery & Lightbox for Flickr, SmugMug, Google Photos & Others » Flickr collection thumbs not showing

  • onlineopvoedhulp

    (@onlineopvoedhulp)


    Hi, We are having an issue that the Flickr collection mosaic is not showing, it is empty. The mosaics are created in Flickr so the issue is not there. Any idea how we can solve this? Thanks…

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Sayontan

    (@sayontan)

    I believe this is a Flickr API bug – it was brought up a few months back and it happens because Flickr’s API tells you that there is no mosaic available. It basically returns a generic image.

    If I recall correctly, the way to fix it is to explicitly generate a mosaic for your collection on Flickr, and not rely on the automatically generated mosaic.

    As some background: Flickr made API changes in late 2019 / early 2020, which broke many things. They changed the URL structures, broke how videos are handled etc. I myself have opened bug reports with them. This was one of the many things that changed.

    onlineopvoedhulp

    (@onlineopvoedhulp)

    I actually have already created the mosaics in Flickr before. I did this when I created the Collections.

    So that is not the problem in this case.

    Plugin Author Sayontan

    (@sayontan)

    Flickr’s API is returning a default mosaic for you. Take a look here. You can pass 72157716085897202 as your collection id, and 188989364@N08 as your user id. You can either pass your API key, or sign the call as yourself, and click on “Call Method”. You will see this:

    <?xml version="1.0" encoding="utf-8" ?>
    <rsp stat="ok">
      <collections>
        <collection id="188896551-72157716085897202" title="Algemeen" description="" iconlarge="https://combo.staticflickr.com/pw/images/collection_default_l.gif" iconsmall="https://combo.staticflickr.com/pw/images/collection_default_s.gif">
          <set id="72157715900694651" title="Uurrecord December 2019" description="" />
          <set id="72157715900257371" title="Uurwedstrijd 2019" description="" />
          <set id="72157715900881698" title="Mini-Elfstedentocht 2019" description="Foto impressie van de op 12 januari 2019 verreden Mini-Elfstedentocht" />
          <set id="72157715904680192" title="Mini-Elfstedentocht 2018" description="Foto impressie van de op 6 januari 2018 verreden Mini-Elfstedentocht" />
        </collection>
      </collections>
    </rsp>

    You can try the above for any of your collections.

    Note the values for iconlarge and iconsmall – they both point to default images, and Flickr is not returning your true mosaic. This is a problem at Flickr’s end. One option is to disable the thumbnails for the headers when you are generating your galleries.

    Okay, great!

    You are suggesting the following:
    “One option is to disable the thumbnails for the headers when you are generating your galleries.”

    How do I do this and where?

    Should I contact Flickr about the thumbs? Would I get anywhere with their support?

    Thanks, much appreciated.

    Plugin Author Sayontan

    (@sayontan)

    How do I do this and where?

    If you are using the Gallery Wizard, in the step “Configure Your Layout” (i.e. the last step), there is an option that says “Show Header”. This is set to “Default from Settings”, but you can change it to any of the other options over there. If you want to use this setting everywhere, the best way is to leave this option to “Default from Settings”, and go to Photonic → Settings → Flickr → Collections. You will see an option to “Hide Collection Thumbnail”.

    Should I contact Flickr about the thumbs? Would I get anywhere with their support?

    You could, but I haven’t had any luck getting a response from them.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.