WordPress.org

Support

Support » How-To and Troubleshooting » Flickr API End Point

Flickr API End Point

Viewing 15 replies - 1 through 15 (of 42 total)
  • I´m having exactly the same problem.

    It can be confusing but its really simple.

    To use Flickr the API # is not the API number you are thinking of. The API IS! The address they are showing you.

    API = http://www.YOURBLOG.com/blog/xmlrpc.php

    Enter that exact thing filling in your blog name into the field and you should be good to go.

    Cheers

    I am having this problem as well – tried using the address they gave and checked to see if I have the xmlrpc.php file. Any other ideas?

    basically, don’t type “http://”

    this still doesn’t work. Is there some security that might be restricting it? I am so frustrated. It used to work, now all of a sudden it doesn’t.

    I’m having this problem as well. Very annoying.

    I was having trouble with this too. These:

    brendadada.com/blog/xmlrpc.php
    http://www.brendadada.com/blog/xmlrpc.php
    http://www.brendadada.com/blog/xmlrpc.php

    didn’t work, but this did:
    http://www.brendadada.com/xmlrpc.php

    hope that helps.

    I have tried every combination possible of syntax, that isn’t it. Any more (different) suggestions

    @jjklcoke: Your xmlrpc endpoint is http://www.klockes.com/xmlrpc.php – the file is definitely there. If Flickr can’t connect, then something else is the problem.

    @anyone else: “/blog/” in efenili’s example should be replaced by the location you have WordPress installed. This might be “wordpress” if you’ve put it in a folder called “wordpress” or nothing at all if you installed in the root of your site.

    Hmmm…I am having a similar issue, the file is definitely there in my root directory, but Flickr keep saying the endpoint I entered is not correct. Do I have to alter the permissions for the file or something?

    The link i used was http://www.pjpolo.com/wordpress/xmlrpc.php for my website. Note the insertion of the /wordpress/ subfolder as described by LesBessant. I think most people have this setup.

    I found a workaround that worked for me. I was about to give up after trying all of the combinations described above, and then I changed the type of blog that I was trying to get Flickr to connect with. Instead of a wordpress setup, I choose metaweblogapi from the drop down list and it worked, first time!
    Hope it works for someone else too

    There is a slight problem with that workaround Steve. If you look at the URL, Flickr sends you to the metaweblogapi page regardless of whether you pick WordPress or metaweblogapi.

    I’m actually really surprised that nobody has offered an idea about why WordPress is acting up like this.

    I’ve also got the exact same problem. Flickr and Scribefire will not connect to my wordpress blog’s xml-rpc at wilde-world.co.uk/xmlrpc.php. I’ve tried removing WordPress and reinstalling it, I’ve tried changing the permissions on it and nothing has worked.

    This really is annoying, almost as annoying as the fact that this bug hasn’t really gotten the attention that it should have in the past six months.

    Now, does anyone have an idea why its doing this?!

    *BUMP*

    Still need an answer.

    I’m also having this problem. I’ve reinstalled 4 times, cleared and made new databases, reinstalled in different locations – nothing works. This really is frustrating. Please let me know if anyone finds a solution. It seems there isn’t much out there on this issue yet.

Viewing 15 replies - 1 through 15 (of 42 total)
  • The topic ‘Flickr API End Point’ is closed to new replies.
Skip to toolbar