WordPress.org

Forums

Flickr API End Point (43 posts)

  1. Ryochi
    Member
    Posted 8 years ago #

    Okay folks, I am new at wordpress and also flickr.

    I tried to add my blog at flick but it always end up wrong
    http://whatever.com/blog is my blog address and I saw the XMLRPC files is under my blog folder so, I put http://whatever.com/blog/xmlrpc.php
    but it fails me!

    any advice? please
    I saw the old similar topic but it didn't help me :(

  2. zannin
    Member
    Posted 8 years ago #

    I´m having exactly the same problem.

  3. efenili
    Member
    Posted 8 years ago #

    It can be confusing but its really simple.

    To use Flickr the API # is not the API number you are thinking of. The API IS! The address they are showing you.

    API = http://www.YOURBLOG.com/blog/xmlrpc.php

    Enter that exact thing filling in your blog name into the field and you should be good to go.

    Cheers

  4. jordanandsam
    Member
    Posted 8 years ago #

    I am having this problem as well - tried using the address they gave and checked to see if I have the xmlrpc.php file. Any other ideas?

  5. azarethroy
    Member
    Posted 8 years ago #

    basically, don't type "http://"

  6. jjklocke
    Member
    Posted 8 years ago #

    this still doesn't work. Is there some security that might be restricting it? I am so frustrated. It used to work, now all of a sudden it doesn't.

  7. loudestnoise
    Member
    Posted 8 years ago #

    I'm having this problem as well. Very annoying.

  8. brendadada
    Member
    Posted 8 years ago #

    I was having trouble with this too. These:

    brendadada.com/blog/xmlrpc.php
    http://www.brendadada.com/blog/xmlrpc.php
    http://www.brendadada.com/blog/xmlrpc.php

    didn't work, but this did:
    http://www.brendadada.com/xmlrpc.php

    hope that helps.

  9. jjklocke
    Member
    Posted 8 years ago #

    I have tried every combination possible of syntax, that isn't it. Any more (different) suggestions

  10. @jjklcoke: Your xmlrpc endpoint is http://www.klockes.com/xmlrpc.php - the file is definitely there. If Flickr can't connect, then something else is the problem.

    @anyone else: "/blog/" in efenili's example should be replaced by the location you have WordPress installed. This might be "wordpress" if you've put it in a folder called "wordpress" or nothing at all if you installed in the root of your site.

  11. Birks
    Member
    Posted 8 years ago #

    Hmmm...I am having a similar issue, the file is definitely there in my root directory, but Flickr keep saying the endpoint I entered is not correct. Do I have to alter the permissions for the file or something?

  12. simdog6294
    Member
    Posted 8 years ago #

    The link i used was http://www.pjpolo.com/wordpress/xmlrpc.php for my website. Note the insertion of the /wordpress/ subfolder as described by LesBessant. I think most people have this setup.

  13. SteveUK
    Member
    Posted 8 years ago #

    I found a workaround that worked for me. I was about to give up after trying all of the combinations described above, and then I changed the type of blog that I was trying to get Flickr to connect with. Instead of a wordpress setup, I choose metaweblogapi from the drop down list and it worked, first time!
    Hope it works for someone else too

  14. Prestwick
    Member
    Posted 8 years ago #

    There is a slight problem with that workaround Steve. If you look at the URL, Flickr sends you to the metaweblogapi page regardless of whether you pick WordPress or metaweblogapi.

    I'm actually really surprised that nobody has offered an idea about why WordPress is acting up like this.

    I've also got the exact same problem. Flickr and Scribefire will not connect to my wordpress blog's xml-rpc at wilde-world.co.uk/xmlrpc.php. I've tried removing WordPress and reinstalling it, I've tried changing the permissions on it and nothing has worked.

    This really is annoying, almost as annoying as the fact that this bug hasn't really gotten the attention that it should have in the past six months.

    Now, does anyone have an idea why its doing this?!

  15. Prestwick
    Member
    Posted 8 years ago #

    *BUMP*

    Still need an answer.

  16. jasonOnWordpress
    Member
    Posted 8 years ago #

    I'm also having this problem. I've reinstalled 4 times, cleared and made new databases, reinstalled in different locations - nothing works. This really is frustrating. Please let me know if anyone finds a solution. It seems there isn't much out there on this issue yet.

  17. Chris_K
    Member
    Posted 8 years ago #

    @prestwick - I pointed my browser at http://wilde-world.co.uk/xmlrpc.php and got a 404.

    Where's your xmlrpc.php. If you can't browse to it, no other service is going to find it either.

    @jasonOnWordpress - tried browsing to you xmlrpc.php? What were the results? Anything in your web server's error logs?

  18. jasonOnWordpress
    Member
    Posted 8 years ago #

    it's there 100%.
    http://www.nealksdaf.com/xmlrpc.php

    I've also installed in subfolders of the same domain, changed permissions on the files...etc.

  19. Chris_K
    Member
    Posted 8 years ago #

    Did you notice that when your pointed your browser at it, you got a 403 (forbidden)?

    That's not a good omen.

    Does your host block all outside access to xmlrpc.php?

  20. Chris_K
    Member
    Posted 8 years ago #

    Wait. There isn't a blog at http://www.nealksdaf.com/

    Got a 403 there too.

    Where's your blog? The xmlrpc.php *there* is the one you want to use.

  21. jasonOnWordpress
    Member
    Posted 8 years ago #

    I have it .htaccess protected

  22. chaoticmortalcom
    Member
    Posted 8 years ago #

    Temporarily remove .htaccess (or change it). Test it. If the xmlrpc works, then that's the problem. if it still doesn't work, plug it back in.

  23. Chris_K
    Member
    Posted 8 years ago #

    To repeat: If *I* can't browse to it, neither will any other outside service.

  24. jasonOnWordpress
    Member
    Posted 8 years ago #

    I've tried that. I'm wondering... is everyone experiencing this problem trying to use xmlrpc.php from flickr only? It seems that way. What other sites out there have api integration with wp so I can test and rule out it being a "flickr problem"

  25. Chris_K
    Member
    Posted 8 years ago #

    Pretty much every Weblog_Client uses xmlrpc.php. They work for me on my blogs. Probably worth trying one as a test. (aside: I'm rather fond of the windows live writer (beta) client. It even uploads files via the api...)

  26. jasonOnWordpress
    Member
    Posted 8 years ago #

    Oh wow, I really am that stupid. When I tested without the .htaccess block I threw in a meta tag redirect in it's place. (you know so I wouldn't have people navigating to it while I was setting it up). Thank you Handy Solo. I apologize everyone for my stupidity. It's working now.

  27. jasonOnWordpress
    Member
    Posted 8 years ago #

    now I'll just throw back in that block so I can resume working on it now that flickr is up and running.
    Thanks again HandySolo

  28. Chris_K
    Member
    Posted 8 years ago #

    Good deal - thanks for the followup!

  29. Prestwick
    Member
    Posted 8 years ago #

    @HandySolo, sorry about that, I was in the process of reinstalling WP manually rather than through Fantastico. Still no dice.

    XMLRPC is now at http://www.wilde-world.co.uk/blog/xmlrpc.php

    Sorry for the confusion, I had almost given up hope!!! :)

    EDIT: Sorry, I forgot to mention that I am having issues trying to integrate WP with Scribefire.

  30. skingery
    Member
    Posted 8 years ago #

    I'm having this issue as well. Odd thing is, Windows Live Writer works fine. Can't get Flickr or Blip.tv to work. Both seem to think the endpoint is incorrect.

    http://www.techlifeweb.com/xmlrpc.php gives "XML-RPC server accepts POST requests only." so that should be ok.

Topic Closed

This topic has been closed to new replies.

About this Topic