Support » Plugin: MetaSlider Lightbox » FlexSlider

  • Resolved webcart

    (@webcart)


    Hi
    I use Carousel mode in the Flexslider of MetaSlider plugin and all works fine.
    But the speed is changing during the presentation.
    I need to make it same speed all the way from first picture to the last.

    Furthermore, when it arrives the last picture, it goes back all the way and I need
    it not to go back but to go for the first picture.

    Thanks in advance ๐Ÿ™‚

Viewing 15 replies - 1 through 15 (of 18 total)
  • Plugin Contributor kbatdorf

    (@kbat82)

    Hi @webcart,

    Do you have a link to the site? I might be able to get a better idea what the issues are.

    And now I see another problem – The slider does not appear on FireFox…

    Plugin Contributor kbatdorf

    (@kbat82)

    Hi @webcart,

    Can you add this to your css somewhere?

    .flexslider .slides {
        transition-timing-function: linear;
    }
    function stop_slideshow_when_finished($options, $id) {
    
    	$options['end'] = isset($options['end']) ? $options['end'] : array();
    	$options['end'] = array_merge($options['end'], array("slider.stop()"));
    
    	return $options;
    }
    add_filter('metaslider_flex_slider_parameters', 'stop_slideshow_when_finished', 10, 2);

    I didn’t spend time testing this, but let me know if you try it out and it doesn’t work.

    • This reply was modified 1 year, 2 months ago by kbatdorf. Reason: Better formatting
    • This reply was modified 1 year, 2 months ago by kbatdorf. Reason: Removed the word public

    Thanks.
    I put the second code in functions.php but get an error:
    “syntax error, unexpected ‘public’ (T_PUBLIC), expecting end of file”

    Plugin Contributor kbatdorf

    (@kbat82)

    Sorry, remove the word “public”

    Great! It solved the speed issue and now the speed is same speed all the way ๐Ÿ™‚

    Is there a way to make the last picture go to the first picture and not go
    back ?

    And what about the FireFox ? I have FF 62.0.2 and the slider not showing there…

    By the way, in the code I see that the slider stops ?
    I do not want it to stop…

    Plugin Contributor kbatdorf

    (@kbat82)

    Hi @webcart

    Is there a way to make the last picture go to the first picture and not go back ?

    This is not possible. The alternative solution as I mentioned above is to have it stop at the end. If you don’t want this, then you will have to remove that php function.

    For FireFox, my guess is you have to add this style:

    .metaslider .flex-viewport {
        direction: rtl;
    }

    Thanks.
    The above code did not solve the FireFix problem.
    Reagrding the loop / stop of the slider –
    What code to put if I do NOT want the slider to stop ever and
    I need that the speed of the pictures will be the same speed all the
    way – Like it is now.
    …just cancel the stop

    Plugin Contributor kbatdorf

    (@kbat82)

    Try:

    .metaslider .flex-viewport {
        direction: rtl !important;
    }

    To make the slider NOT stop, remove the code I gave you, as in:

    Remove this:

    function stop_slideshow_when_finished($options, $id) {
    
    	$options['end'] = isset($options['end']) ? $options['end'] : array();
    	$options['end'] = array_merge($options['end'], array("slider.stop()"));
    
    	return $options;
    }
    add_filter('metaslider_flex_slider_parameters', 'stop_slideshow_when_finished', 10, 2);

    All work ! Thanks !
    The important of the !important…:)
    Thanks again for the plugin and the great support…

    Plugin Contributor kbatdorf

    (@kbat82)

    Anytime! I’ll add to our list of future features the idea of continuously scrolling, but I don’t know when/if it will be ready.

    By the way, if youโ€™re enjoying MetaSlider please leave us a 5-star review. They really help us out. If you don’t think we deserve the 5 stars please let us know how we can improve. Thanks!

    https://wordpress.org/support/plugin/ml-slider/reviews#new-post

    Hi again,
    Found out today that on Safari browser the slider is not working.
    Is there any code I should put in like you gave me for FireFox ?
    Thanks

    Further to the above thread, the problem is in the following code

    .metaslider .flex-viewport {
        direction: rtl !important;}

    If I remove it, the slideshow will appear on Safari but NOT in Firefox.
    If I enable it, the slideshow will appear on Firefox but NOT in Safari.
    Any idea…?

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘FlexSlider’ is closed to new replies.