Support » Plugin: Table Rate Shipping Method for WooCommerce by Flexible Shipping » Flexible Shipping Rates Not Showing

  • Resolved gooffy294

    (@gooffy294)


    Hi, it used to work but suddenly, it stopped working.

    When customers select their country, the shipping says:

    “No shipping options were found…”

    But other rates set outside flexible shipping works.

    I see other people complaining about this, guess it’s a bug in the plugin or something

    I have enabled the debug option in the shipping options tab but it fixes nothing.

    The page I need help with: [log in to see the link]

Viewing 11 replies - 1 through 11 (of 11 total)
  • Thread Starter gooffy294

    (@gooffy294)

    PS: it doesn’t show the rates in either checkout or cart.

    It just says: “No shipping options were found…”

    • This reply was modified 1 year, 1 month ago by gooffy294.
    Plugin Support lusp

    (@lusp)

    Hi @gooffy294,

    Usually such notice is related to the incorrect configuration. Could you please attach the screenshots illustration how your shipping zones and shipping methods are currently configured?

    Kind regards,
    Łukasz

    Thread Starter gooffy294

    (@gooffy294)

    Here, I got this csv from your website here. I imported it to test, it didn’t work too:

    https://imgur.com/a/XZpSqoc

    • This reply was modified 1 year, 1 month ago by gooffy294.
    Thread Starter gooffy294

    (@gooffy294)

    Now, after deactivating and deleting the plugin then re-installing, the shipping option shows but the per kg rate doesn’t calculate.

    I added in a product of 0.45kg to the cart, it reads the base rate but adding 10 of the same product calculates the same initial rate.

    This is my current configuration here

    The (0.45kg) product I tested it with here

    Thread Starter gooffy294

    (@gooffy294)

    Shipping Zone: https://imgur.com/a/BlLmUxt

    Shipping method: https://imgur.com/a/1VlnIZ6

    Flexible Shipping: https://imgur.com/a/7lqJUIk

    Plugin Support lusp

    (@lusp)

    Hi @gooffy294,

    Thank you for your reply. I’ve just run a test, added the product you’ve mentioned above to the cart and hit the ‘Cart’ button. No shipping options were displayed at this point due to the not entered shipping details here:

    https://wpdesk.me/ls/zm356.png

    If not entered, WooCommerce will match it by default to Locations not covered by your other zones shipping zone. When I entered some sample UK shipping address, the Int’l Shipping was matched and the PGL Service shipping method appeared:

    https://wpdesk.me/ls/o9nfg.png

    When I updated the products quantity to 10, the shipping price did not change:

    https://wpdesk.me/ls/55a5g.png

    I believe there might be something wrong with this product’s setup. Could you please attach the screenshots showing how it is configured?

    Kind regards,

    Plugin Support lusp

    (@lusp)

    Since there are no further inquiries concerning this case I’m marking this thread as resolved.

    Kind regards,
    Łukasz

    Hello @lusp,

    I think we have the same problem. Can you help us out?

    Thank you in advance

    Plugin Support lusp

    (@lusp)

    Hi @rgegeo,

    Sure, I can take a look at your current setup. Could you post the screenshots illustrating how are your shipping methods and zones configured at this moment and provide me with some more details about the product you used for testing when the rates were not displayed?

    Kind regards,
    Łukasz

    Plugin Support lusp

    (@lusp)

    Hi @rgegeo,

    Thank you for the screenshots. What is the weight unit you are currently using in your shop? Is it g as it is displayed here?

    https://wpdesk.me/ls/dkwme.jpg

    If so, I believe the first problem is the weight ranges you’ve defined e.g. here:

    https://wpdesk.me/ls/k1bd6.jpg

    On the first glimpse they look like if they were meant for kg instead of g. So, in order to make it work I believe you should unify the weight units and either change it to kg in the WooCommerce settings and modify the products’ weight or leave it in g and adjust the shipping cost calculation rules to be configured for g as well.

    The second thing which got my attention is the fact that there are some gaps between your weight ranges you’ve. If these rules are meant for kg:

    https://wpdesk.me/ls/gsnwr.jpg

    the first one ends at 2 kg and the next one starts at 2.1 kg, so the 2.001 – 2.099 weight range remains currently uncovered. When the products’ in the cart weight hits this range, your customer will get the “There are no shipping methods…’ notice. That’s why it’s highly advised to keep that in mind and prevent such gaps from happening while defining the rules. To solve this out your weight-based rules should look this way:

    0-2 kg – 6
    2.001-3 kg – 1
    3.001-4 kg – 1
    etc.

    The last thing I’ve noticed is the wrong shipping zones order. The narrower ones should be placed higher than the wider in order to be considered first. That’s why you should move the Peloponesse to the top and lower the Greece:

    https://wpdesk.me/ls/5w3eq.jpg

    If not, all the shipping addresses will be matched to the Greece shipping zone since it’s much wider and being at the very top it will be considered first.

    I hope that all my suggestions above will help you with solving the problems you’ve encountered.

    Kind regards,
    Łukasz

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Flexible Shipping Rates Not Showing’ is closed to new replies.