• Resolved mark_harding

    (@mark_harding)


    Flexbox displays correctly on live page, but not in FSE editor.

    In the FSE editor, columns are stacked instead of side-by-side.

    • This topic was modified 3 months, 1 week ago by mark_harding.

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Support Ojoma a11n

    (@geraltrivia)

    Hello there @mark_harding ,

    Thank you for reaching out to us regarding the Flexbox display issue you’re experiencing in the Full Site Editor (FSE) on your WordPress site.

    From your description, it sounds like columns which should be displayed side-by-side (as per Flexbox layout) are instead stacking vertically within the FSE editor, though they display correctly on the live page.

    It’s important to note that this particular issue may not be related directly to MailPoet, especially if you’re not experiencing any similar issues with MailPoet emails or forms. MailPoet is primarily focused on email and newsletter features, and does not have functionality that would typically interact with how Flexbox or layout behavior is handled in your theme or in the WordPress editor.

    With that said, here are a couple of troubleshooting steps that might help:

    1. Confirm CSS Rules: Review your CSS rules to ensure that nothing is accidentally causing your elements to stack in the FSE editor. Styles can behave differently in the editor view from the frontend live page view. Remember that the FSE editor might be applying some default CSS rules which are differing from those applied in the frontend view.
    2. Test in a Different Theme: To check if this is a theme-specific issue, try temporarily switching to a default WordPress theme like “Twenty Twenty-One” and see if the problem persists. If the issue is resolved, there may be something in your current theme’s CSS or layout settings that are conflicting with the desired Flexbox behavior in the editor.
    3. Plugin Conflict Test: Although it’s less likely that a plugin is causing this issue, it’s still worth conducting a plugin conflict test. You can temporarily deactivate your plugins one by one and check the FSE editor after each deactivation to see if the issue gets resolved. Do ensure to take a backup before proceeding with this step.

    If you can’t pinpoint the issue after attempting these steps, I would recommend reaching out to your theme’s developer directly or seeking advice from a wider community such as a WordPress support forum. They may have more insights on the specific behavior of Flexbox within the FSE.

    We’re here to help, so if there are any issues or questions related to your MailPoet subscription or newsletters, feel free to ask.

    Thread Starter mark_harding

    (@mark_harding)

    Thanks!

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.