WordPress.org

Support

Support » Reviews » Captain Slider » flex slider have to work on mobile

flex slider have to work on mobile

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author Captain Theme

    @captaintheme

    I never said that it would work with touch movements on mobiles, but in some cases it still does. Regardless, I never said this was a feature of the plugin so you should be including it in a review.

    Thanks for the comment

    sorry, I already fixed it. Just added link to mousewheel plugin in the header near body + changed in javascript, vertical to horizontal direction (with fade effect). Now everything works 🙂 But, 1 problem is still there: it doesn’t work with IE7. Flex slider is ok with ie7, I have it on another site (without wp plugin). But with your plugin on wordpress, ie7 not showing slideshow, seems like jquery problem.

    Plugin Author Captain Theme

    @captaintheme

    Plugin is definitely not IE7 compatible. Please remove/update review so people know it’s not 2 stars 🙂 (am yisrael hai!)

    updated 🙂 can u make it compatible? flex slider is compatible, why not to make it so on wp plugin? also maybe add (optional) mousewheel jquery plugin, it will work on mobile then 🙂

    direction: ‘horizontal’ in js with mousewheel plugin script will make it touchable

    Plugin Author Captain Theme

    @captaintheme

    Could you please link me to the mousewheel plugin you’re using? Nothing should really be different from flexslider as the plugin just uses flexslider jquery script and then makes it work well with WordPress. Also, what options are you using with flexslider to get the results you want? Let me know so I can add them as settings for the plugin.

    Cheers
    Bryce

    the plugin comes with the slider, when you download from http://flexslider.woothemes.com/ inside demo folder js jquery.mousewheel.js – when you are using touch movement it should be horizontal in initiation js
    animation: ‘fade’, // Specify sets like: ‘fade’ or ‘slide’
    direction: ‘horizontal’,

    one more things u can use:

    in css add :

    .home .flexslider .slides > li {
    display:none; /* loading slides without flickering */
    }

    maybe try to include slider code at the footer, we need ie7 🙂

    Plugin Author Captain Theme

    @captaintheme

    I’ll add that as an option in next version. Next version also uses imagesLoaded plugin so slider does not load until all image shave , so no need for that CSS 🙂

    HI!

    Working on another site with your slideshow. This modification is enough to make it work with touch on ipad with fade effect on slides:

    direction: '<?php if ( $effect == 'slideh' ) { echo 'horizontal'; } elseif ( $effect == 'fade' ) { echo 'horizontal'; } else { echo 'vertical'; } ?>',

    in captain-slider.php – latest version.

    thanks.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘flex slider have to work on mobile’ is closed to new replies.
Skip to toolbar