Support » Theme: Nictitate » Flashing Menu and icons

  • I’ve begun experiencing a strange quirk on this theme in the menu. At random times, when I hover over a menu in the main navigation, the menu and icon begin to flash and will not stop. Clicking does nothing, refreshing does nothing. If I click the header image, it will take me back to the home page where sometimes it stops flashing, but other times it begins again almost immediately. I haven’t been able to recreate this behavior on a Mac, by the way. It’s only on a PC that it’s happened. The browser was Firefox. Any clues?

Viewing 9 replies - 1 through 9 (of 9 total)
  • It’s throughout the site: http://www.workforcereadysystem.org/newsite/

    I should say, I’ve only been able to get it to happen on a PC.

    Andrew Nevins

    (@anevins)

    WCLDN 2018 Contributor | Volunteer support

    I would start removing unnecessary styles on your menu, things that you wouldn’t expect to see. Like z-index on the <li>. Have you set up a child theme, or are you using a custom css plugin?

    No custom CSS plug in or child theme. There are a couple of other plug ins I can deactivate. I will try and report back. Thanks!

    Andrew Nevins

    (@anevins)

    WCLDN 2018 Contributor | Volunteer support

    Because you can’t replicate the issue, I don’t think deactivating plugins will help you debug this. Do deactivate a plugin if it’s not necessary, but if you’re deactivating and reactivating then you probably won’t see a difference.

    Are you familiar with CSS, would you know how to override the theme’s z-index styles?

    I know enough to be dangerous, but am willing to give it a go.

    Andrew Nevins

    (@anevins)

    WCLDN 2018 Contributor | Volunteer support

    I’d recommend you do those CSS modifications in a Custom CSS plugin. Let us know how you get on.

    Thanks. Will do!

    I’ve been able to consistently recreate this error.

    If you navigate to any page on http://www.workforcereadysystem.org and scroll down enough so the top of the menu bar is touching the top of your browser, you can recreate it.

    None of the links in the menu bar are clickable until you scroll back up. If you try to hover over any menu item it flashes.

    It appears that something is wrong with the Kopa background element.

    Scroll as I mentioned before and hover on any nav item. Instead of only triggering the dropdown, it triggers the kopa-bg element which interferes with the menu’s z-index.

    Is there something that can be done to fix this bug?

    I got a solution from the theme developer:

    you can add this to Theme Options > Custom CSS to fix the bug:

    #main-nav
    {
    z-index: 99999;
    }

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Flashing Menu and icons’ is closed to new replies.