WordPress.org

Support

Support » How-To and Troubleshooting » Flash uploader logs out during “Crunching…” phase

Flash uploader logs out during “Crunching…” phase

  • After upgrading to 2.8, one of my blogs won’t let me upload any files via the Flash uploader. When I try to do so, I get a log-in prompt during the “Crunching…” phase, and so the file never gets uploaded.

    – This problem only happens to one of my three blogs. All three of them are using 2.8, and all three of them have had clean installs (i.e. previous files were deleted and then reuploaded, didn’t use WP’s built-in upgrader)

    – Although the log-in prompt pops up, WP itself doesn’t actually log out. If I close the media manager and go to another section of WP, for example, I am still logged in.

    – I’ve upgraded to the latest version of Flash. I’ve tried using Firefox, Google Chrome, and even Internet Explorer. This problem occurs on all three browsers.

    – The log-in window pops up for each individual upload I do. So for example, if I try to upload 15 images at once, I get 15 log-in windows in a row. If I log in to one of them, I get a “Are you sure you want to do this?” message. When I click the “Please try again” link, I’m taken back to the main page of the media uploader… where none of my files have been uploaded.

    – Using the regular browser uploader works just fine; however, since that one blog happens to be a photo blog, you can imagine that I’d want to be able to upload more than just one file at a time. Thus, I’d really, really, REALLY appreciate it if I could use the Flash uploader again.

    Any help on the matter would be greatly appreciated! Thanks!!

Viewing 15 replies - 1 through 15 (of 22 total)
  • I installed the NextGEN-Gallery plugin to try and circumvent the WP uploader problem. I’ve found that the NGG plugin also logs me out for each individual image upload. HOWEVER, I’ve discovered that zip uploading works normally (albeit a tad unstable, with random connection timeouts to the server).

    Are you using FF? The uploader is working for me under IE, just not FF.

    I hate having to resort to workarounds. It seems that this has been a problem for long enough that someone would have dealt with it by now…

    Yeh, about time they dealt with it.
    This happens to me the times the FF crunches animated gif’s.

    It doesn’t work for me regardless of browser. I’ve tried FF, IE, and Google Chrome, and none of them let me upload files through the Flash uploader.

    I’m having this problem too – please provide a fix 🙁

    OK guys it seems to be plug in related.
    I upgraded all my plugins this evening and it’s now working again.
    Here’s a list of my plugins, can’t remember which I upgraded but if you’ve got this problem it’s worth cross-referencing yourself.

    Akismet
    All in One SEO Pack
    Star Rating for Reviews
    Subscribe2
    Twitter for WordPress
    WordPress.com Stats
    WP-EMail
    WP-Print
    Xavin’s Review Ratings

    I’ve disabled all plugins and Gears, still no dice. Argh…

    Although I’m not being logged out during this process the flash uploader, and normal browser uploader, get “stuck” after the file is completely uploaded. Weird.

    This is really p***ing me off. I’m having the same problems. Just hangs at crunching. What is the deal? I also have disabled all plugins, still no dice.

    Come ON wordpress?????????

    Anyone at all? I really still can’t figure this out.

    any solution please?

    I had similar issues when I first started building my site (which is my first & so far only WordPress site). My experience is it’s the size of the image files themselves. With WPMU 2.7.1, the files would get uploaded & thumbnails & other size versions of the images would get created, but I couldn’t do anything with them.

    It turns out that there are settings (you got me as to which ones) that the code is using to determine what the largest size of image, in term of pixels (file size doesn’t matter) that you can upload to your site. If your images are all of that size or smaller, they should upload without issue.

    So take some of your files & make them smaller, say 1024×768 & see what happens when you upload them that size.

    Tony

    Tony,

    Thanks for the advice, but my images are actually 900×600.

    jp

    Moderator kmessinger

    @kmessinger

    my images are actually 900×600

    What dpi?

    This is how I fixed this problem of log-in screen popping up. My blog is within a protected directory and I have a similar problem with the members section log-in prompt popping up.
    Well actually the log-in box still pops up but I only have to enter my user/pass once per session. Then all images upload, compared to the multiple log-in screens and the uploader crashing. I tried most solutions from the boards, disabling plugins, htaccess fixes, screwing with the swfupload file which made things worse, non of it worked.

    *What I did,
    I downgraded from Adobe Flash Player 10 to Flashplayer 9.
    Uninstall Flash Player 10
    Link to uninstall program at Adobe site is here
    Download Flash Player 9 here
    Flash Player 9 is a huge file at 198MB since it has every build of version 9.
    -Ok so close all browser windows and whatever else uses flash
    -Uninstall flash with program
    -Restart computer
    -Go to flash 9 file, Use the latest 9 build in the file “9r246”
    For Firefox/Chrome to install flash run: flashplayer9r246_win.exe
    For IE run: flashplayer9r246_winax.exe
    Restart browser, clear your cache and try the image uploader. If you get a log-in pop up enter your login info and see if the images start uploading. The first image uploaded might be broken, just refresh or do a test run.
    Let me know if this helps

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘Flash uploader logs out during “Crunching…” phase’ is closed to new replies.