WordPress.org

Forums

Haiku minimalist audio player
Flash Player Update Required Message (8 posts)

  1. Katherine
    Member
    Posted 2 years ago #

    I recently installed the updated version of Haiku Audio Player and am receiving a message saying I need to update my flash player to the current version. I am using Google Chrome, and it tells me that Flash player is updated automatically.

    The box appears on page load, and stays put until the text player has fully loaded (i.e. there is a total time for mp3 clip showing). It seems to be tied to the haiku-no-solution class, and I can set it to display:none, but the page load is still impacted by the message.

    You can see what is happening at this URL: http://www.kfumc.org/see-hear/listen-to-sermons/?sermon_id=154

    I am using a custom theme with the latest version of WordPress. Thanks in advance for any help you can provide.

    http://wordpress.org/extend/plugins/haiku-minimalist-audio-player/

  2. johanronstrom
    Member
    Posted 2 years ago #

    The player on your page works for me, Firefox 19.0.2, Win7. Maybe you found a solution? Resolved?

  3. Katherine
    Member
    Posted 2 years ago #

    No, I never got it "resolved" - my solution was to remove the code in the plug-in files itself. I never heard from the developers, so I did what I had to do for the best user experience.

    I also tried it on Safari, same issue. I did not try it on a different computer.

  4. francoisromain
    Member
    Posted 2 years ago #

    same problem here : I have a blinking error message before the player loads.

    everything works fine except this blinking error.

    wp 3.5.1
    haiku player 1.0

    I hope you could solve it and thank you to the dev for this nice plugin btw.

  5. crispinfreeman
    Member
    Posted 2 years ago #

    Katherine: What code did you remove? I'm having the same issue on my site: http://www.voiceactingmastery.com

    I like your redesign of the player. Did you do that by making a custom player using the custom player settings, or did you fiddle with the code directly?

  6. Janelle
    Member
    Posted 2 years ago #

    If you put this code in your theme's main stylesheet, the message won't display:

    div.haiku-no-solution {
    display: none;
    }

    The player still seems to take a moment upon page load to "situate itself" but this does at least get rid of the big box with the flash message so it helps!

  7. crispinfreeman
    Member
    Posted 2 years ago #

    Thanks so much Janelle!

    Does it matter where I put that code in the stylesheet? I'm a bit of a noobie to CSS.

  8. Katherine
    Member
    Posted 2 years ago #

    Janelle: I tried your solution at first, but the page load time was still WAY longer than what I was comfortable with. It will not display it, but the code behind it still executes.

    crispinfreeman: I removed `<div class="haiku-no-solution">
    <?php _e('<strong>Update Required</strong><br><span>To play the media you will need to either update your browser to a recent version or update your <a href="http://get.adobe.com/flashplayer/" target="_blank">Flash plugin</a>.</span>', 'haiku'); ?>
    </div>`

    I show it as line 306 in haiku-player.php.

    I also used the css to redesign the player, I did not use a custom player since I am using the text version, not the graphical player. Hope that helps.

    Anyone from Haiku want to weigh in?

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Haiku minimalist audio player
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic