Support » Fixing WordPress » Flash movie in header

  • Resolved xpressprints


    Hello all. I’m using the nightlife theme for a client, and I’m trying to replace the top image with this flash movie as done here. It’s not showing up, however if you right click and choose view background image, the swf loads in a new window. Any ideas on how I can get this to display in the header. Thanks!

Viewing 14 replies - 1 through 14 (of 14 total)
  • Please… suggestions please? Thanks.

    It’s a cakewalk, you can simply use the <object> tag or a javascript called SWFObject.
    The SWFObject also get rid of the annoying IE7 “press space bar or enter to activate and use this control” that appears on embedded flash.
    You can get SWFObject here:
    just add the jacascript call to your header. If you need help with it just ask.

    After that simply add the following code just below <div id=”header”>

    <script type="text/javascript" src="swfobject.js"></script>
    <div id="flashcontent">
      This text is replaced by the Flash movie.
    <script type="text/javascript">
       var so = new SWFObject("http://yourswflocation/header.swf", "mymovie", "860", "180", "8", "#000000");

    otherwise, without the SWFObject javascript as follow:

    <OBJECT classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000"
    WIDTH="860" HEIGHT="180" id="swfheader"><PARAM NAME=movie VALUE="http://yourswflocation/header.swf"><PARAM NAME=quality VALUE=high><PARAM NAME=bgcolor VALUE=#FFFFFF><EMBED src="http://yourswflocation/header.swf" quality=high bgcolor=#FFFFFF WIDTH="860" HEIGHT="180"
    NAME="swfheader" ALIGN="" TYPE="application/x-shockwave-flash"

    Adjust the swf path to your needs.

    Hope this helps

    Thanks, the link you provided actually times-out and doesn’t load. I used the code you provided for placing the movie without SWFObject, and it works fine in firefox, but not at all in IE. Any suggestions?

    Actually I just noticed that this only works on the main page. When I navigated to other pages, the header did not show, but when I place this code in the header file itself it works – BUT only in FF. I’ve yet to see this play properly in IE. HELP!

    Someone? themystical? moshu? whooami?Please I want to get this client’s site out of my hair!

    hmmm… sorry, I am busy with my clients 😉




    hah, you want ME to help with you something you are doing for a client? You dont know me very well, apparantly. My brain does not get picked by ppl that are getting paid to do jobs, sorry. At least not willingly.

    I’ll give you ONE hint — and if you had ANY decent experience doing something besides manipulating an occasional .psd you would already know this:

    its a path problem.

    (A perfect example of why a self-confessed “graphic designer” should not do web sites)




    great minds think alike moshu 😛

    Wow, I wasn’t expecting a bashing – I know that we all have projects and clients to deal with. I just know that you guys help people out a lot on the forums, and I thought maybe I could get some help from you guys, that’s all.




    That wasnt a bashing .. and I dont have clients, 🙂 But if I did I would make sure I understood what I was getting into, thoroughly. Your question indicates a lack of knowledge regarding something that is very basic to “Internet technology”.

    Besides, I gave you a hint.

    whooami and moshu – for the record I did not mean to offend anyone, I just see you 2 around a lot, and I know that you’re very skilled and helpful, that’s all.

    whooami – this was so painfully simple that I’m kicking myself for looking like a fool. thanks so much for your hint.

    also, I’ve been working in the world of web for a while, but I’m new to wordpress and the newer versions of CSS. I’m just looking for a little help here guys. Sorry for the ignorance, I hope this doesn’t deter you guys from helping me in the future. thanks!



    Hello all,
    I have a flash slideshow for the header of the site. I just realised that when people do not have a Flash player installed on their browser, they just get a blank at the top of the page, with the words header.swf which is not pretty. What can I do to give some other message so that they realise that they are not seeing the image for that reason. They will not see the slideshows on the site either, so if they could get an early warning, that would be great.

    Currently I have this code in the header.php:

    between the <head></head> tags I have this: <script type=”text/javascript” src=”/swfobject.js”>
    Then I have the folloiwng code after the div header:
    <div id=”flashcontent”>
    <script type=”text/javascript”>
    var so = new SWFObject(“”, “mymovie”,
    “770”, “175”, “8”,

    I have changed the line in the head section to read this:
    <script type=”text/javascript” src=””>

    this gives the full path, but even then, if someone has javascript disabled, they just see the words header.swf where the slideshow ought to be.

    Any ideas anyone? Brain cells are completely wracked here.



    xpressprints, it would be great if you showed the script that solved the problem for you.
    I’m having similar issues and I think seeing how your issue was resolved would help me.

    I have the same problem My swf is in the images folder and I know it must be a path problem. What was your fix?

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Flash movie in header’ is closed to new replies.