WordPress.org

Support

Support » Themes and Templates » Flash header cause white box in IE

Flash header cause white box in IE

  • Hello there, I’m using the Nightlife theme. I actually replaced the header with a flash movie, but I’m noticing that there’s a big white rectangle underneath it. This only appears in IE both 6 and 7. I’ve tested in Firefox, and Opera for PC and Safari and Firefox for Mac and it looks great. Suggestions? Thanks in advance!

Viewing 9 replies - 1 through 9 (of 9 total)
  • Here’s the site the flah banner is on: http://www.weloftyou.com

    Any help is greatly appreciated. Thank you!

    Does anyone have any potential solutions to this please? Thanks!

    You are loading the movie with the object tag. Microsoft has done some wired things with the new intenet explorer. I use a file called “Run_AC.js” it allows me to run a flash movie using javascript. This method although it’s not “xml valid” works on all modern browsers. Adobe has released tech notes and the java here: http://www.adobe.com/devnet/activecontent/articles/devletter.html
    it’s a bit confusing but it has seamed to work for me.

    Brandon

    hello xpressprints

    I see you got your flash banner working in both ie and ff how did u do this??

    I cant find the solution??

    fl1pp3r

    @fl1pp3r

    same problem here

    http://www.mixzmaster.com its my site

    Moderator kmessinger

    @kmessinger

    fl1pp3r, you have many validation errors, some of which will give you problems with flash. Check at http://validator.w3.org/

    xpressprints

    @xpressprints

    Brandon:
    Thanks so much for your response. My issue isn’t so much with active content. There’s no need for the user to interact with the movie. I did give the article a read though, and I also followed all the steps and could not get my movie to load for some reason.

    Dulwich:
    Here’s the code that I used: `<object classid=”clsid:d27cdb6e-ae6d-11cf-96b8-444553540000″
    codebase=”http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,0,0″
    width=”861″ height=”180″ id=”WeLoftYouFlashBanner”>
    <param name=movie value=”http://www.weloftyou.com/wp-content/themes/nightlife/images/header.swf”><param name=quality value=high></object>`
    Maybe you’re theme will react differently, I sure hope it does.

    Does anyone have any clue what’s causing this box uinder the movie in IE? Does it have something to do with the way the theme is built? I remember someone posting that they had the same issue, and when they found the solution, they posted saying it was fixed, but didn’t share the issue or how to correct it. At this point the website is complete and the header is the last thing that needs to be fixed. Switching themes sounds like a great idea right now, but I’d rather find a solution.

    Thanks to everyone, your support is greatly appreciated! =)

    Moderator kmessinger

    @kmessinger

    Here is some information found when googling autostart flash in IE7. Hope it helps.

    http://www.kirupa.com/developer/flash8/flash_fix.htm

    Also I use a java script like BrandonRandon that is Xml transitional valid that looks like this.

    <script type="text/JavaScript">
    <!--
    function MM_openBrWindow('width=400,height=340') { //v2.0
      window.open('width=400,height=340');
    }
    //-->
    </script>
    
    <script type="text/javascript">
    AC_AX_RunContent( 'classid','CLSID:6BF52A52-394A-11d3-B153-00C04F79FAA6','width','400','height','340','class','pictureC','id','player','url','http://www.savethecolors.com/WordPress/assets/Videos2/press1forEnglish.wmv','autostart','true','controller','true' ); //end AC code
    </script><noscript><object classid="CLSID:6BF52A52-394A-11d3-B153-00C04F79FAA6"  width="400" height="340" class="pictureC" id="player">
            <param name="url" value="http://www.savethecolors.com/WordPress/assets/Videos2/press1forEnglish.wmv" />
    
              <param name="autostart" value="true" />
              <param name="controller" value="true" />
            </object></noscript>

    Perhaps you could use this with a swf on page load.

    http://wordpress.org/support/topic/195985 check this links guys , seems same problem for all , really isnot any good method to embade flash without header problems for resolutions ?? that makes me crzy

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Flash header cause white box in IE’ is closed to new replies.
Skip to toolbar