Support » Themes and Templates » Fixing Theme for 2.8

  • Hello all,

    I am having a problem bringing a Theme into the 21st century. Here is the loop code, what needs to be updated there to get it to work with 2.8? There is plenty of other stuff broken with the site that I a working on fixing (I didn’t create it), but this is one of the problems. Thanks!

    <?php
    					$my_query = new WP_Query('cat=27&showposts=3');
    					if ($my_query->have_posts()) {
    
    						$n=1;
    						 while ($my_query->have_posts()) : $my_query->the_post();  ?>
    
    							<div class="block_post_wrapper">
    
    								<div id="latest_news_<?php print $n; ?>" class="block_post">
    
    									<?php
    									$content = content('Read More...');
    									$contenti = extract_image( $content, 'homepage', 204, 205, true );
    
    									print '<img src="'.$contenti['resize'].'" class="align" />';
    									?>
    									<small class="meta"><?php the_date('F j, Y'); ?></small>
    									<h3><a href="<?php the_permalink() ?>" rel="bookmark" title="Permanent Link to <?php the_title_attribute(); ?>"><?php the_title(); ?></a></h3>
    
    									<?php
    									if ($post->post_excerpt) {
    										the_excerpt();
    									} else {
    										print $contenti['content'];
    									}
    									 ?>
    
    								</div>
    
    							</div>
    						<?php
    						$n++;
    						endwhile;
    					}
    					?>
Viewing 1 replies (of 1 total)
Viewing 1 replies (of 1 total)
  • The topic ‘Fixing Theme for 2.8’ is closed to new replies.