WordPress.org

Support

Support » Themes and Templates » Fixing how CPTs displayed on the home page

Fixing how CPTs displayed on the home page

  • Dan

    @daniel-berhane

    Hello,
    I managed to create two CPTs and make them appear on the home page by adding codes to the functions file.

    However, they are being displayed differently on the home page, no matter what I do to.

    As you may see here: One post using the default post type, another using ‘aside’ post type appear with a white background, while the CPTs do not have such appearance.

    I don’t intend to make much use of the built-in post-types, so I tweaked the theme to show no excerpts, so that the home page simply displays headings of the CPT. In that case, I wouldn’t have mind that the CPTs are displayed without the default white background.
    But, as you can see, it leaves too much space below each title.

    Would any one help me ASAP?
    Thanx.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Dan

    @daniel-berhane

    If you notices the “DISPLAY; NONE” text at the top of the site and also at the bottom of the left sidebar. I recall putting that text into the CSS and/or one of the widgets. But I can find it any where, so can’t remove it.

    [Note that: It is semi-colon not colon after the word “display”]

    WPyogi

    @wpyogi

    Forum Moderator

    I recall putting that text into the CSS and/or one of the widgets. But I can find it any where, so can’t remove it.

    Yes, looks like that’s in a widget – a search widget possibly?

    Are there theme options for widgets or the header or what’s under Appearance > Widgets?

    As to the space on the home page, don’t know what you did or where, but some of it is from this CSS:

    .teaser .entry-summary {
        height: 64px;
        overflow: hidden;
    }

    I’d also strongly recommend using a child theme for modifications to theme files – otherwise your changes will be lost when the theme is updated.

    For future questions, you should post on the theme’s dedicated sub-forum:

    http://wordpress.org/support/theme/esplanade#postform

    Dan

    @daniel-berhane

    Oh, I thought this post will be placed on that form if I tagged it with Esplanade.
    Can moderators move this post to that forum?

    Moderator Jan Dembowski

    @jdembowski

    Volunteer Mod. & Brute Squad

    Can moderators move this post to that forum?

    ‘Fraid not. If you can re-post to that forum then I’ll close this topic with a link to that one.

    http://wordpress.org/support/theme/esplanade#postform

    Please do not just post a link to this topic, recreate the post above. 😉

    Dan

    @daniel-berhane

    @wpyogi
    I recall putting that “display none” into a widget, but I removed the widget later.
    Even if I empty the header widget and the top sidebar widgets, it remains on the menu bar.
    Yet, removing the search widget from the left sidebar helped on that part.

    So, I will need to figure out what code I changed in the php files concerning menu or search.

    I wrote this to make the thread and your reply helpful to whomever might read it.
    (As for me, I can re-install the theme if need be to get rid of it)
    ————

    Regarding the tweaks I made on the homepage teasers, I think I know what I did.
    Should I reply here or on the new thread I started as per your recommendations? http://wordpress.org/support/topic/how-to-fix-cpts-appearance-on-the-home-page?replies=1

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Fixing how CPTs displayed on the home page’ is closed to new replies.