Fixing Fatal Error: Allowed Memory Size gets me more errors? (3 posts)

  1. katuchan
    Posted 3 years ago #

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 30720 bytes) in /home/applesim/public_html/wp-admin/includes/theme.php on line 50

    I know, it's nothing new. It's all over google. I've tried adding "@ini_set('memory_limit','64M');" to my wp_config.php, and also "define('WP_MEMORY_LIMIT', '64M');". With the first, I get "Fatal Error, unexpected @ statement on line 2," and with the second, "Unexpected t-statement on line 2."

    I also added "RLimitMEM max" to my .htaccess. Nothing is working. I recently got a "too many inodes" warning email from my host provider, and I suspect it's due to too many installations of WP. Since I recently found out about setting up a multisite, I figured that would be a good solution. I suspect that this memory issue is due to the same problem, but I unfortunately can't get my multisite set up if I can't access my dashboard (that I know of). I'd really appreciate some advice on this issue.

  2. katuchan
    Posted 3 years ago #

    Also I don't seem to have a php.ini or an install.php file in my base directory, which were two other suggested solutions.

  3. esmi
    Forum Moderator
    Posted 3 years ago #

    Contact your hosts for assistance. Not all hosts allow site-specific php.ini files or allow you to adjust PHP memory allocation via your .htaccess file.

Topic Closed

This topic has been closed to new replies.

About this Topic