Support » Plugins » Fixes to make OpenID work on PHP 5.3

  • Hi,

    I had problems with this plugin in PHP 5.3, as it has changed the requirements for references in call_user_func* functions.

    I’ve had a look and fixed them in my version:

    line 1576
    array(&$message, $this->server));
    line 1702
    return call_user_func($handler, &$request);

    I expect this is backwards compatible with PHP 4. There may be other call_user_func* calls that need changing however I only found these which are necissary to authenticate with.

    Could these changes be added to the plugin?

    http://wordpress.org/extend/plugins/openid/

Viewing 3 replies - 1 through 3 (of 3 total)
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Fixes to make OpenID work on PHP 5.3’ is closed to new replies.