Support » Plugin: Bitcoin and Altcoin Wallets » Fixer.io limit problems

  • Hi, I thought I posted about this before but cannot find it now.

    I get warning from fixer.io that my free allocation is used up 100%, usually around the middle of the month. This makes it impossible to purchase anything, giving an error about no exchange rates being available, please try another currency.

    I don’t really care about showing banker currency rates, but even when I turn all of it off it seems woocommerce doesn’t share my disdain for fiat and still will not work.

    I have another site with woocommerce and wallets plug-in but that is fine. I can’t see why it is exceeding the limits.

    It’s strange because the fiat conversion is showing in the balance section:
    https://postimg.cc/qNTZ694n

    any insights appreciated.

    • This topic was modified 10 months, 4 weeks ago by  clickforafrica. Reason: added note and image link

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author dashed-slug.net

    (@dashedslug)

    Hello,

    As discussed before, if you are requesting exchange rates every 5 minutes, that sums up to 30*60*24/5 = 8640 requests per month.

    If you set exchange rates to be requested say, every 10 minutes, the number of requests would be half.

    Every installation that you have set up to pull exchange rates from fixer would make its own set of requests.

    If you do not need exchange rates with fiat at all, you can disable this exchange rates provider altogether.

    kind regards

    Yes I tried disabling it, (assuming this is the way to do that)
    https://postimg.cc/4YxV051q

    Maybe if I wait a while, there may be some caching going on. Unless I have not actually disabled it in the image above. It’s still showing the USD amount.

    It does say “App extensions, such as the WooCommerce and Events Manager payment gateways, use exchange rates for price calculation. Choose which external API or APIs will be used to pull exchange rates between various cryptocurrencies.”

    Even if I only have one currency active? I set the default fiat currency in woocommerce to —. I tried setting it to LTCT as well, having added that manually, but that doesn’t work either. When I set them up they were working fine.

    I have separate fixer account for each site. Clickforafrica works fine, it’s something to do with woocommerce. Every day I curse the insane world of banker currencies.

    Plugin Author dashed-slug.net

    (@dashedslug)

    If you uncheck fixer from the list of exchange rates providers, the plugin will not use the remote API. Also, if you do not provide an API key, the plugin will not use the remote API.

    The last exchange rates that were loaded will be used. If you wish to delete these, you can delete the option wallets_rates. If you are using wp-cli you would do wp option delete wallets_rates.

    If the WooCommerce default currency is the same as the one that the user is attempting to pay with, then you do not need any exchange rates providers for the payment gateway extension to work.

    Hope this helps. Let me know if you face more problems with this.

    • This reply was modified 10 months, 4 weeks ago by  dashed-slug.net. Reason: added paragraph about plugin always using last rates retrieved
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Fixer.io limit problems’ is closed to new replies.