Support » Plugin: Search By Category » FIXED: Support for WP 3.5

  • The parameter name used in the form for searching by category is incorrect. Fortunately, it is very easy to modify the code to fix this.

    1. Edit search-by-category.php (It’s in the “wp-content/plugins/search-by-category” directory)

    2. Next, change the phrase ‘cat’ to ‘category’ on the following lines:

    237:  $cat_id = (int)$_GET['category'];
    252:  'name' => 'category',
    268:  $cat_id = $_GET['category'] ? (int) $_GET['category'] : 0;
    303:  if ( isset($_REQUEST['s']) && isset($_REQUEST['category']) ){
    306: $desired_cat = $_REQUEST['category'];
    311:  $wp_query->query_vars['category'] = "-{$excluded}";

    This restores the search functionality. I haven’t tested it for exclusions because I don’t need it. If someone else wants to test for exclusions, post the results here and I will fix if neccessary.

    http://wordpress.org/plugins/search-by-category/

Viewing 2 replies - 1 through 2 (of 2 total)
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘FIXED: Support for WP 3.5’ is closed to new replies.