Support » Themes and Templates » fixed it! missing themes

  • i just spent a couple of hours going jelly-brain, but i’m happy to say it’s fixed, so i thought i’d share, incase others have the same problem.

    i could not see the themes in the ‘presentation’ admin page. not the default two themes or any new uploaded themes. i eventually found (from a post here) about the permissions issue, so i went around 777’ing lots of files, but that didn’t help. eventually i figured out that you can set permissions for files aswell (maybe i’m stoopid, but i didn’t make this idea-leap at first) so i 777’d the wp_content file itself (and enclosed items for good measure) and now i can see themes. yippeeee!


Viewing 4 replies - 1 through 4 (of 4 total)
  • whooami



    while that seem like a great solution, its not — youve introduced more potential for trouble later than you are aware of.

    The MINIMUM permissions your wp-content/ DIRECTORY (and any directorys within it) require is 755.

    The MINIMUM permissions FILES inside wp-content/ require is 644

    777 is world-writable, and not an advisable permission over the long term for security reasons.

    In short, thats terrible advice, especially for someone that might come here without a basic understanding of file permission settings (im guessing you have little, if any, as well) and their effects.

    That’s true, that’s a security risk.

    But, what should we do? I upgraded my baseball blog to 2.0.4 and I can’t switch themes, the default theme always comes up. That’s why I haven’t upgraded my personal blog.

    I’ve been waiting for an answer to this in the forum but haven’t seen or read a solution yet.

    Sorry for my english.





    frankpereiro, while I see your previous posts about this, I also see that you havent actually provided a link to the blog where your problem is. Personally, I try not to give advice without actually looking at the site first.

    That said, the original poster in this thread didnt say she was having an issue with the theme “changing”, she said she didnt _see_ themes in the presentation menu.

    No file, whether it be a text file or any other needs to be _world-writable_ for it to be “seen”, it needs to be _world-readable_, which is exactly what chmod 644 accomplishes.

    Your problem, as I understand it is completely different than hers. Since youve already started a few threads..

    PS: Your english is just fine. In fact it seems better than some seemingly native English speakers Ive read on here.

    Thanks whooami, I thought I did post a link to my baseball blog but obviously I didn’t. The link is:

    Maybe you could give me some advice on what is going on with the templates “not sticking” (sort of say).

    I just started one thread about this, then I replied on some others that I thought faced the same problem as mine. My problem is that every time I choose some template, it goes back to the default. I don’t understand why.


Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘fixed it! missing themes’ is closed to new replies.