Support » Plugin: TablePress » Fixed Header Is Not Working

  • Resolved Niran Muller

    (@kaku571)


    Hi Tobias.!
    Thank you for the great plugin. I reviewed 5 stars & donated 2 times for your great addons.

    On my website, the Fixed header is not Working.
    Everything is updated. When I disable all plugins, & changed the theme, then it will work. (But the fixed header will spread to the entire screen width making confuse to respective columns)
    I will pay you for your great work.
    Can you solve my problem?
    Please email me to niranjanbhat20@gmail.com, I will send you my staging website login information.
    I know you are busy and expensive. But still, I believe I am lucky to get your email!
    Thanks
    Have a nice day!

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author TobiasBg

    (@tobiasbg)

    Hi,

    thanks for your post, and sorry for the trouble.

    Can you please post a link to the page with the table where this problem happens, so that I can take a direct look? Thanks!
    That might be faster than having me to log in, which often is not necessary for such problems 🙂

    Regards,
    Tobias

    Thank you so much for replying & Sorry for the late reply.
    My website table url- websitebuilderly.com
    Scroll a little bit, you will find the table.
    1)The fixed header is not working
    2)all plugins disabled & changed the theme, then fixed header works, but (when only 2 or 3 columns exist) the fixed header spread to the entire screen width and makes confuse to its respective columns

    Thanks

    Plugin Author TobiasBg

    (@tobiasbg)

    Hi,

    can you maybe temporarily turn off the JavaScript minification and concatenation feature (in your caching plugin)? That might help us debug here.
    Also, please check if the TablePress FixedHeader Extension is installed AND activated. Then, please also check if the “Use DataTables” checkbox on the table’s “Edit” screen is checked (the individual feature, like sort, search, etc. can be turned off, if you don’t want to use them).

    Regards,
    Tobias

    Thank you for the reply.
    What I are the things I did.
    1) I hosted my website in Kinsta.
    2) I migrated my site to Kinsta Staging environment So that no cache or any other issues will happen in Kinsta.
    3)I deactivated all the plugins except Tablepress & fixed header addon. But no table header get freeze while scrolling
    4) I changed the theme to twenty-nineteen, but not worked. then switched to the highest minimal theme -> skelementor, But not worked..!
    5)Then created a new test table. YESSSSS.. It worked..!
    6) Then I inserted old table & newly created table in the same page. Surprise …! Newly created fiexed header worked..! I checked all the javascript library But not worked for the old table.

    7) The changed to my original generatepress theme. But still new one worked, but old one not worked. 

    8) New one colum number is 3. So Then I deleted old table’s number of columns from 8 to 3 to test it. But not worked.

    9) Then I inserted new row for heading for old table. But still not working.

    My staging website link is here -> https://staging-david1.kinsta.cloud/

    Tablepress & everything is updated to the latest version. Php version 7.3
    The surprising thing is newly created table is working, but the 2nd one old table is not working in the same page..!!!

    Can you help me?

    10) Then I disable Plugin option – CSS load, still not working..!

    I checked everything in the table option as well as a javascript library. I will donate you. Please help me.

    YesSSSSSSSSS.. I got a BUG for you..!!
    11) Then I deleted colspan rows. Then it worked..!!!
    12) If I used #colspan#, then no javascript library will work even I ticked like sorting. Scrolling, fixed header etc.

    • This reply was modified 2 months, 1 week ago by Niran Muller.
    • This reply was modified 2 months, 1 week ago by Niran Muller.
    Plugin Author TobiasBg

    (@tobiasbg)

    Hi,

    I’m afraid that this is not really a “bug”, but a known thing. Unfortunately, the external DataTables JS library is not compatible with combined/merged cells in a table (via #colspan# or #rowspan#). You can read more in the help text when you click the small “?” button next to the “colspan” and “rowspan” button on the “Edit” screen.
    So, yes, if you remove all #colspan# and #rowspan#, everything should work 🙂

    Best wishes,
    Tobias

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.