Support » Plugin: Yet Another Related Posts Plugin (YARPP) » Fixed conflict between YARPP and W3TC

  • Resolved creyes123


    I recently installed Yet Another Related Posts Plugin (YARPP) and started experiencing problems with settings not getting saved, similar to what others have reported. I disabled W3 Total Cache (W3TC) and the problems went away. So I reenabled W3TC and selectively disabled parts of it until I isolated what was causing the issue.

    I use Amazon CloudFront as a pull CDN. I had listed the plugins directory in the list of custom files to host with the CDN. As soon as I removed this, the problem went away.

    My website has been live for about a year and I have about 50 plugins installed. Thinking back, I experienced a similar issue with Newsletter Sign-Up when I launched the website that I never quite resolved. I have not gone back to test this, but my hunch is that this other issue has just gone away, too.

Viewing 12 replies - 1 through 12 (of 12 total)
  • Thank you so much for letting me know. These reports have been tricky, as I have not been able to reproduce these bugs myself… are you still using Amazon CloudFront? If you’re using another CDN, has it also been affected? Do you know if any other parts of W3TC, like the Object Cache, had any effect?

    Thank you!

    I disabled the Object Cache in W3TC and it had no effect. The problem was still there. I also disabled the W3TC Page Cache and Database Cache. No effect there, either.

    I am still using Amazon CloudFront. It is the only CDN I use.

    The fix I mentioned let me resize the thumbnails using the add_image_size(‘yarpp-thumbnail’, …) call in my functions.php file. That was the main problem I was trying to solve.

    But the plugin is still forgetting about the setting to use thumbnails instead of the default list. I tried disabling every other plugin and the problem was still there. It is definitely not related to W3TC.

    @creyes123 thanks again for the detailed notes.

    Losing the “thumbnails” setting has been reported in another thread as well. I want to understand better how this happens… if you wouldn’t mind, could you try these steps and report what you get?

    1. open two tabs, one with admin and one with a page where YARPP is displayed.
    2. In tab A, open YARPP settings. Set to List display and save. When the page refreshes, saying “settings updated”, does it show that List is turned on?
    3. Go to tab B and reload. Does it show the List display?
    4. In tab A, set to Thumbnails display and save. When the page refreshes, saying “settings updated”, does it show that Thumbnails is turned on?
    5. Go to tab B and reload. Does it show the Thumbnails display?
    6. In tab A, go to another part of the admin, and then go to YARPP settings (not with the browser back button). Does it still show that Thumbnails are on? (Do not change settings now.)
    7. Go to tab B and reload. Does it still show the Thumbnails display?

    Sorry that’s pretty long. Thank you!

    1. (no question was asked)
    2. Yes, List is still turned on after page refresh on settings page.
    3. Yes, List display is on tab B.
    4. No, after saving the List display was (incorrectly) selected.
    5. Yes, tab B showed the Thumbnail display.
    6. No, List display is still selected.
    7. No, now it shows the List display.

    Hope that helped!

    @creyes123 This helps me a lot. What browser are you using? What version of WordPress is this?

    I run ArchLinux on my desktop. It is the latest version. My tab A was on Firefox 17.0.1 and my tab B was Chrome 23.0.1271.97. I believe these are both the latest versions. I just upgraded to WordPress 3.5, though the problem was also there with the previous version (3.4.2?).

    I have FireBug and FirePHP installed in my Firefox browser. If you have a version of your plugin with debugging output enabled, I would be happy to install it and post the console output.

    In the meantime, I got around the problem in my production server by hard coding the Thumbnails display choice. It seems to be working fine otherwise. I would love to see a version where the vertical height for the thumbnail titles is variable, but otherwise the plugin is meeting all my needs.

    @creyes123 there’s information in the FAQ on how to adjust the thumbnail size.

    I’m having trouble reproducing the Thumbnails setting bug, but I’ll dig around a bit more. If you don’t mind, it would help if you sent me some debug information about your site. If you go to YARPP settings > help tab > optional data collection and copy the text in there, that would help me reproduce your environment. If you don’t want to post it here, you can email me at Thanks!

    Yes, the add_image_size() function call in my functions.php file is what I used to resize the thumbnails. It was not working before because of the conflict with the Cloudspace CDN setting. That is now fixed.

    I emailed you the debug information from my production server.

    Carlos Reyes

    Glad you figured out the CDN issue.

    I believe I’ve fixed the settings issue in this new beta, 4.0.3b1. Please give it a try:

    Indeed! I just tested it and it worked fine. Nice job, and thank you.

    Wonderful! I hope to push this out as 4.0.3 soon… there’s one other bug I hope to quash soon.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Fixed conflict between YARPP and W3TC’ is closed to new replies.