Support » Plugin: RPS Image Gallery » fix your update my blog doesn't load

  • Resolved mjkpitt

    (@mjkpitt)


    I just ran the update for RPS Image Gallery and now my blog doesn’t load because of an error, how do I download a previous version or can this be fixed. The blog is a MAJOR part of my site and this needs fixed. I can’t even remove the plug-in!

    Fatal error: Invalid opcode 153/1/8. in /blog/wp-content/plugins/rps-image-gallery/dependencies/rpsslideshow/autoload.php on line 8

    My blog is at http://www.buymixtapes.com/blog

    I can’t even login to my wordpress, that error is on every page!

    https://wordpress.org/plugins/rps-image-gallery/

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author redpixelstudios

    (@redpixelstudios)

    The link you provided seems to be loading fine at the moment. Have you done something to correct the issue?

    Plugin Author redpixelstudios

    (@redpixelstudios)

    On further investigation it looks like you are running the latest version of RPS Image Gallery, 2.1.3 and not experiencing the error, which is good. Our best guess, based on the error, is that the environment in use by the blog may have had an issue with the use of an anonymous PHP function. Please let us know if this continues to be an issue for you so we can look into a resolution. Thanks in advance.

    I paid someone $20 on upwork to fix it. They made some changes and said this “yes the current latest version has issues with some PHP version let me find the replacement of that function which is causing the problem then you can use it but remember not to update it”

    “it has lots of conflict with current version of wordpress, so just wait for new update from author that will be better for you , there are lots of changes in the plugin which are not currently supported in PHP properly”

    Plugin Author redpixelstudios

    (@redpixelstudios)

    Understood. We are glad you were able to get everything going again and regret any trouble and anxiety you experienced. We do make every effort to create quality code and test thoroughly, though we cannot guarantee it will work seamlessly in every environment.

    To our knowledge, RPS Image Gallery does not have any conflicts with the current version of WordPress or versions of PHP 5.3.0+, and we would require specific information as to how it was conflicted to address the issues.

    Is there any chance you could provide us with additional details as to what was changed in the plugin to make it work with your environment? Perhaps you could send us an archive of the modified version of RPS Image Gallery you are running so we could compare the differences and investigate the fixes implemented by the upwork technician. The information would of course go a long way to make certain the next version of RPS Image Gallery works for you without issue.

    Thanks in advance for your assistance and understanding.

    I replied with a link to the modified archive, but I don’t see it. I zipped up the contents of the plug-in folder

    Plugin Author redpixelstudios

    (@redpixelstudios)

    We just realized that you had a question we did not answer from the initial support post. You had asked how to download a previous version of the plugin. Luckily all plugins hosted at WordPress.org are under version control.

    Access to previous versions is available by visiting the “Developers” page associated with the plugin. For RPS Image Gallery, the Developers link is https://wordpress.org/plugins/rps-image-gallery/developers/. Look for the heading “Other Versions” and find the version number you wish to download and click the link. A ZIP archive will be downloaded by your browser.

    Once you have the ZIP archive in hand, you will need to connect to your WordPress install via FTP or some other file management utility. Delete the folder containing the problematic version of the plugin and then upload the expanded version of the ZIP archive.

    Hope this information helps in the future.

    Plugin Author redpixelstudios

    (@redpixelstudios)

    No worries. If you don’t mind, you can send the link to the archive via the contact form on our website. We really appreciate your followup on this issue. Thanks again.

    I emailed the zipped up archive as an attachment and as a link, I posted the link before but I don’t know how that goes on this forum as I don’t see the post.

    I sent the link in your contact forum

    Plugin Author redpixelstudios

    (@redpixelstudios)

    We received the link and were able to download the ZIP archive of the patched version of RPS Image Gallery.

    We will leave this issue open and respond to you after we have analyzed the modifications. Thanks for providing the information.

    Plugin Author redpixelstudios

    (@redpixelstudios)

    It seems there are three minor modifications to the plugin files, all having to do with avoiding the use of anonymous functions. Just for reference, anonymous functions were introduced in PHP 5.3.0 and your blog’s server is running 5.3.29. However, there must be some other variable in the server environment having trouble processing them.

    General queries for “Invalid opcode 153/1/8” point to a caching utility called eAccelerator, which is not compatible with anonymous functions. Assuming your server environment is running eAccelerator, it is possible you will run into issues in the future with other plugins as the use of anonymous functions is becoming more commonplace, so changing caching solutions could be a consideration.

    It may also be time to speak with your hosting provider about an upgrade to PHP. As it turns out, PHP 5.3.29 reached end of life a while back and is no longer supported. “Users of this release should upgrade as soon as possible, as they may be exposed to unpatched security vulnerabilities.”

    As you can probably surmise from the minimal number of plugin modifications and their nature, the analysis of the upwork technician was a bit of an overreach to say the least. That being said, we will gladly replace the three occurrences of the anonymous functions in the RPS Image Gallery code for the next release so the next update will be a much better experience for you.

    Thank you again for sticking with us through the troubleshooting and diagnosis of the issue. Please let us know if there is anything we can do in the meantime to make RPS Image Gallery work better for you.

    Plugin Author redpixelstudios

    (@redpixelstudios)

    We have just committed RPS Image Gallery 2.1.4 which should address the anonymous function incompatibility. It would be excellent if you would download and test to make certain we have sufficiently addressed the issue. Once we receive word from you we can then update the stable tag to make the update available through the standard WordPress update process. Please let us know your findings or if it is inconvenient for you to do the testing. Cheers!

    Plugin Author redpixelstudios

    (@redpixelstudios)

    We finished testing and released RPS Image Gallery 2.1.5 yesterday. Give it a try and let us know how it works out for you. You definitely will not run into the same issue with your server environment this time since the anonymous functions have been replaced.

    Plugin Author redpixelstudios

    (@redpixelstudios)

    Since we haven’t heard from you in a couple of days, we’re going to assume the issue is resolved. Feel free to reopen or post a new issue if necessary. Don’t forget to update your review if you believe RPS Image Gallery deserves it. Thanks much!

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘fix your update my blog doesn't load’ is closed to new replies.