WordPress.org

Forums

FIX - WordPress doesn't work on the LAN (1 post)

  1. pdxchambers
    Member
    Posted 4 years ago #

    So I don't know if this is the correct forum for this, but I wanted to share a problem I was having and how I fixed it.

    In a nutshell my problem was that WordPress worked perfectly fine if I accessed it from outside my LAN, but when I attempted to access the production server from within my LAN I would get the site content, but the style sheet wasn't applied and I could not access wp-admin. I hunted for a solution, but all I could find was advice to change the WordPress and site addresses within the dashboard, however if I did that I would break the production version of the site.

    Obviously, this didn't sit well for me.

    The solution I came up with was to simply add an entry in my hosts file that pointed the web server's local address to my domain. Pretty simple, although I can't say if it would work for those of you who run MacOS or Linux or some other not Microsoft OS. I suppose you could modify the local DNS to do something similar if that is an option for you.

    Anyway, I have been trying to resolve this problem for a long time now and thought I would try and spare someone else the pain. Hope it helps!

    Cheers!

Topic Closed

This topic has been closed to new replies.

About this Topic

  • RSS feed for this topic
  • Started 4 years ago by pdxchambers
  • This topic is not a support question
  • WordPress version: 3.0

Tags