Support » Plugin: Yoast SEO » Fix the white XML sitemap errors caused by non-working XSL.

Viewing 8 replies - 1 through 8 (of 8 total)
  • I noticed in another string to edit the sitemap.xml to delete the XML stylesheet. I was ASTONISHED to see that the following line was the top line in that file:

    <?xml version=”1.0″ encoding=”UTF-8″?><?xml-stylesheet type=”text/xsl” href=”http://www.tabletraven.com/wp-content/plugins/google-sitemap-generator/sitemap.xsl”?><!– generator=”wordpress/2570″ –>

    I had been playing with the google-sitemap-generator two weeks ago and had deleted it in favor of W3 Total Cache. Apparently it left the call to the non-existent stylesheet in the xml file.

    Bottom line is I deleted that line and now I have sitemaps…..sort of…they still look like this:
    http://www.tabletraven.com/sitemap_index.xml

    Google can read it. I just checked in Webmaster Tools. Just not formatted with a stylesheet now. 🙂

    SO I just PERMANENTLY fixed my problem (I hope). If your sitemap comes across as html (per google) or simply is white try THIS:

    In W3 Total Cache under Browser Cache, uncheck “Prevent caching of objects after settings change “. IT WORKS!!!

    After your guidance i do same as you describe here. but still error found in firefox and showing blank page in chrome. you can see here

    http://designmain.com/sitemap_index.xml

    please sort out my problem.

    thanks in advance.

    It should work with W3TC page cache activated, mine is fine

    Hi

    I have problem whit this non-working XSL to. Way cannot this be fix some time?

    Same exact thing happens to me. This started happening after the last update, and nothing seems to work. I’ve been scouring the forums for a fix, but like I said, nothing works. I am also using W3, but was having no problems before the last update.

    A blank page is loaded, or xsl sheet is not found. Sometimes, I get lucky with chrome, and something is shown, but it’s not pretty. Just text.

    http://fitness-for-everyone.com/sitemap_index.xml

    I’ve tried using another plugin to generate the sitemap – but it doesn’t generate the trailing slashes I need for certain pages, so they’re not getting indexed.

    http://fitness-for-everyone.com/sitemap.xml

    I have both up for now – but have the sitemap generator deactivated. I wish the Yoast team would work on a fix.

    I recommend in the meantime while the fix comes out to add a symbolic link to the XSL like explained here:
    http://kx.cloudingenium.com/technologies/wordpress/quick-fix-wordpress-seo-yoast-sitemap_index-xml-giving-blank-page/

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Fix the white XML sitemap errors caused by non-working XSL.’ is closed to new replies.