Support » Themes and Templates » Fix Sidebar

Fix Sidebar

Viewing 14 replies - 1 through 14 (of 14 total)
  • You might wanna try over here for a fix or something. (Alot of fixes for various things for IE problems there.)

    Also here to, since you’re using the K2 theme:

    IE is a pain in the arse when it comes to displaying stuff. Or maybe even someone might help you quicker though here, just just by viewing your CSS and such.. I’m not sure..I can’t really because I’m kinda busy right now.. =)


    Difficult to tell… But it looks like your page template file has misplaced code. Check the position of the sidebar in the template.

    Also, in IE6, I’m getting a javascript error, make sure on the javascripts you have in the sidebar.php or whatever other files is ok.. =)

    Plus these 4 Errors should be fixed then as well. =)


    even if I revert back to original K2 theme CSS, the Sidebar is still messed up — so perhaps it has to do w/ the HTML? When I delete the code I added to make the Photo Gallery and Devotionals appear on every page (adding HTML to the sidebar in the theme editor) it still looks messed up, so I figured it wasn’t the code I imported that made the design mess up.

    why would the sidebar look fine on the homepage and this ‘staff page’:


    :/ I don’t get it.

    Also — I use FireFox w/o much interest in supporting IE kids 😀

    I just viewed it again in both IE6 and FF once…seems that just maybe the search field could be shortened.. :/ Try that once…see what happens..

    Scratch what I said about the devotional thing, here I didn’t have Javascript enabled in FF. Dang thing.. Keeps changing settings on me when I open it up… sigh..

    So I’m not sure really, but like I said, maybe try shortening the search field once..


    how can I shorten the search field?

    ya, I think that’s the problem … why does the search bar get longer on the other pages, can I control this?

    wait — nevermind, take a look at the photo gallery; the search bar isn’t crazy long and it still puts the gallery over the sidebar.


    On that page in IE6, the sidebar is on the left side. :/ Could you maybe not have the sidebar on that page all together? Atleast people will still have the “home” link to get back home at the top nav bar..This way it won’t clutter your gallery either.. just a thought..


    I’ll have to give that some thought. And where I’d place things like the gallery and devotional, I’d prefer there be links to those from all pages.

    Ok. =) It’s up to you, but I have to get off here for now, gotta do some errands and stuff lol..


    ya — and I gotta go to school — I’ll think about it, thanks.

    Alternatively — I guess I could reinstall WordPress, and that should prolly fix it 😀

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Fix Sidebar’ is closed to new replies.