Support » Plugin: Sendy Elements » Fix For Submit Error With Elem Pro 2.9.1

  • Resolved tmgreen

    (@tmgreen)


    Hello,

    Regarding the submission error being generated with the Elementor Pro 2.9.1

    The problem is, for whatever reason, in 2.9.1 the “Utils” Class is no longer located under “Classes”. They have moved it “Core” and done away with Classes altogether.

    To fix the problem, edit the plugin.php file for Sendy Elements and simply change the following line of code from:

    ‘ipaddress’ => \ElementorPro\Classes\Utils::get_client_ip(),

    TO:

    ‘ipaddress’ => \ElementorPro\Core\Utils::get_client_ip(),

    I don’t know if this was intentional or an oversight on their part. I submitted a support ticket from the Elementor site. I’ll post their reply in this thread when I get it.

    Regards,

    Michael

    • This topic was modified 6 months, 1 week ago by tmgreen.
Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Jose Sotelo

    (@josesotelocohen)

    Hello @tmgreen

    You are awesome! Will release a patch 1st thing tomorrow as it’s kind of late here.

    Thank you very much!

    Thanks.

    I have not heard back from Elementor on whether this was intended or an oversight. You might want to hold off until I get an answer. If they fix it on their end, you won’t need to do anything. It just doesn’t make sense that they would move it like that.

    Cheers,

    Michael

    @tmgreen

    Well done for identifying the problem and thanks for the heads up 😉

    I think I’ll wait until Elementor get back to you before I update and if they haven’t made any mistakes with their coding I’ll alter the code snippet you mentioned in the Sendy Elements file.

    tmgreen

    (@tmgreen)

    Jose,

    I’ve not heard back from them. I know there are 3 other bugs pending resolution, and I don’t know if they consider this issue a bug.

    Your call on updating the plugin.

    Regards,

    Michael

    Plugin Author Jose Sotelo

    (@josesotelocohen)

    @tmgreen @mxmark Just released the patch with version 1.0.4.

    The fix is very small so if they change it again it will take me a couple of minutes only.

    Thanks for the help!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Fix For Submit Error With Elem Pro 2.9.1’ is closed to new replies.