Support » Plugin: Cite » Fix for PHP 7.2

  • When upgrading PHP to version 7.2 from 5.x, I received the following warning, which appears under each post the citation appears:

    Warning: Use of undefined constant setting – assumed ‘setting’ (this will throw an Error in a future version of PHP) in <<link to the cite.php file>> on line 105

    The fix to suppress this warning is quite simple.

    Replace:

    $edited_setting = str_replace($find_string, $replace_string, $wpcp_setting[setting]);

    with

    $edited_setting = str_replace($find_string, $replace_string, $wpcp_setting[‘setting’]);

    That should suppress the warnings and resolve issues.

    The page I need help with: [log in to see the link]

  • The topic ‘Fix for PHP 7.2’ is closed to new replies.