WordPress.org

Forums

[resolved] Fix error include wordpress in external website (2 posts)

  1. artinturn
    Member
    Posted 3 years ago #

    Hi all, I've been trying to solve a strange glitch I have with integrating my blog into my website.

    I've got all of my wordpress related content going directly into my <div id="body" section which is the main grey box on my website (http://jeenyee.com/artinturn.php).

    As you can see, the dates are showing up next to the post title but the first two dates are showing up directly next to each other while the third date sets itself next to the second post.

    The code I'm using is as follows

    <div id="blog">
    <?php
    /* Short and sweet */
    define('WP_USE_THEMES', false);
    require('artinturn/wp-blog-header.php');
    ?>
    <h1 align="center"><a class="black large" href="artinturn.php">ART-IN-TURN</a></h1>
    <p align="center">Art Theory, Museums, Life, Blog</p>
    <br/>
    <div id="wpmenu">
    				<div class="wpmenu"><ul><li class="page_item page-item-78"><a href="http://rtconversations.wordpress.com/">RTConversations</a></li><li class="page_item page-item-78"><a href="http://artinturn.wordpress.com/">Read On</a></li></ul></div>
    
    	</div><!--wpmenu close-->
    <?php query_posts('showposts=3'); ?>
    <?php if (have_posts()) : ?>
    <?php while (have_posts()) : the_post(); ?>
    <?php body_class ;?>
    <div class="date">
    <?php the_date('','<h4>','</h4>'); ?>
    <?php the_category('','<p class="small">','</p>');?>
    <?php the_tags('','<p class="small">','</p>');?>
    </div>

    Here is the code for the content site. I've separated the date and the content because I want them to sit in separate columns:

    <div class="content">
    <a href="<?php the_permalink() ?>" rel="bookmark" title="Permanent Link to <?php the_title(); ?>"><?php the_title('<h2>','</h2>'); ?></a>
    <?php the_content('<p>','</p>');?><br/></br>
    </div>
    <br/>
    <?php endwhile; else: ?>
    <p><?php _e('Sorry, no posts matched your criteria.'); ?></p>
    <?php endif; ?>
    </div>

    Thanks in advance to any one who can point me in the right direction!

  2. artinturn
    Member
    Posted 3 years ago #

    If anyone else ever has this problem. Moving the div holding my post titles and dates to BELOW the div holding the content solved the issue instantly.

Topic Closed

This topic has been closed to new replies.

About this Topic