WordPress.org

Support

Support » Localhost Installs » First Time word Press and MAMP

First Time word Press and MAMP

  • Hello, I need some help installing and getting MAMP to run. I’ve watched several tutorials now on how to install and run MAMP, and I still can’t seem to get it to work.

    After installing MAMP It allows me to go to the start page where it tells me I’m successfully running MAMP. I then proceeded to to phpMYadmin page where I created my new database titled JustinCrawford_wp. I then drag wordpress into the Mamp/htdocs/JustinCrawford_wp folder I created. When I then try and access localhost:8888 page I’m greeted with Error establishing a database connection. Am I missing a step? Any suggestions would be greatly appreciated.

    Thanks,

    Justin

Viewing 3 replies - 1 through 3 (of 3 total)
  • you need to update your database setting in the wp-config.php file in the root of your host. This will have a setting for the username, password, database name and database host name. See here.. http://codex.wordpress.org/Editing_wp-config.php

    Make sure the folder path in the Mamp settings matches where you put wordpress. Also make sure your path is right localhost:8888/JustinCrawford_wp/ if that is where the WP files are at.

    I’d reinstall MAMP and keep and eye on where you are installing. ( the path )
    Mine is saved in my “Applications”

    Make sure to check your wp-config and make appropriate changes ( as stated above by alvaw )

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘First Time word Press and MAMP’ is closed to new replies.
Skip to toolbar