First time, install problems (2 posts)

  1. giano
    Posted 11 years ago #

    Ok first here is my wp- config.php file
    <?php /** WordPress's config file **/
    /** http://wordpress.org/ **/
    // ** MySQL settings **
    //define('DB_NAME', 'wordpress');
    // The name of the database define('DB_USER', 'username');
    // Your MySQL username define('DB_PASSWORD', 'password');
    // ...and password define('DB_HOST', 'localhost');
    // 99% chance you won't need to change this value
    // Change the prefix if you want to have multiple blogs in a single database.
    $table_prefix = 'wp_';
    // example: 'wp_' or 'b2' or 'mylogin_'
    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-includes/languages.
    // For example, install de.mo to wp-includes/languages and set WPLANG to 'de'
    // to enable German language support. define ('WPLANG', '');
    /* Stop editing */
    $server = localhost;
    $loginsql = user name;
    $passsql = password;
    $base = mydomain_com_-_wdb;
    define('ABSPATH', dirname(__FILE__).'/');
    // Get everything else
    once I point my browser to the sub domain I created
    http://subdomain.mydomain.com/wp-admin/install.php I get
    the fallowing error.
    Error establishing a database connection! This probably means that the connection
    information in your wp-config.php file is incorrect. Double check it and try again.
    Are you sure you have the correct user/password?
    Are you sure that you have typed the correct hostname?
    Are you sure that the database server is running?
    WordPress Support Forums
    My user name and password is the same user name and password I use to login to
    MySql server with to perform other tasks.
    I am at a loss.
    Any help would be greatfull,
    Thank you

  2. Mark (podz)
    Support Maven
    Posted 11 years ago #

    Have you actually created the database before running the install ?
    WP does not create it, it only creates the tables in it.
    Enusre that you - as user - have full permissions on the database too.

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.