Support » Plugin: Gravity Forms + Stripe » First submission does not get token, form fails. Second submission works

  • Resolved Adam Erstelle

    (@wpgwiggum)


    There appears to be a bug where the first submission of a payment (both one-time user defined payment, and a subscription user-defined amount) form does not succeed, but re submitting the same form (after credit card details clear with error message) works fine.

    Firebug shows the first attempt does not make the POST request to api.stripe.com, but the second attempt does. There are no console errors.

    If there is anything I can do to help figure this out please let me know!

    https://wordpress.org/plugins/gravity-forms-stripe/

Viewing 10 replies - 1 through 10 (of 10 total)
  • Hello,
    I’m facing the same issue. Did you find a solution? Another form on my website works fine. I tried a lot of things but haven’t found yet.
    Thanks!

    As suggested by their support (that I paid for), I troubleshooted by setting theme to WP’s current main theme (twentysixteen). I disabled all plugins but gravityforms, and the stripe gravity plugins. It then began to work…and re-enabling got everything to work.

    In my instance, there was likely an issue due to the order of the initialization of plugins…

    I did have another site where the above steps didn’t work. Turned out that the theme I had converted the shortcode on the page into HTML…incorrectly. Resetting that to the shortcode then got things to work.

    Hopefully this helps!

    Thank you very much! I’ll try it.
    Best regards

    Ali

    (@alijafarian)

    I’m having this exact same error… but none of the above solutions seem to work. My error logging keeps referencing an “Empty token” yet there’s not much context (see logs below):

    2016-09-07 17:38:23.357084 – ERROR –> Empty token
    2016-09-07 17:38:23.357309 – ERROR –> Using a saved credit card. Ignore previous empty token error.
    2016-09-07 17:38:25.467632 – ERROR –> Unable to retrieve list of invoices
    2016-09-07 17:38:25.467900 – ERROR –> PPP\Stripe\Error\InvalidRequest: No such customer: c
    2016-09-07 17:38:25.703583 – ERROR –> Unable to retrieve upcoming invoice
    2016-09-07 17:38:25.703844 – ERROR –> PPP\Stripe\Error\InvalidRequest: No such customer: c
    2016-09-07 17:46:12.133455 – ERROR –> Empty token
    2016-09-07 17:54:11.114726 – ERROR –> Empty token
    2016-09-07 18:01:55.250435 – ERROR –> Empty token
    2016-09-07 18:04:04.711796 – ERROR –> Empty token
    2016-09-07 18:12:44.019682 – ERROR –> Empty token
    2016-09-08 1:03:14.736283 – ERROR –> Empty token
    2016-09-08 1:09:04.050889 – ERROR –> Empty token

    Anybody else running into this? I just downloaded the plugin a few days ago… running with WP 4.6.

    I’m having the same issue. First submission returns ERROR –> Empty token but a second submission will work fine.

    I’m currently stripping the site back to see what is causing the issue, will report back once I have found the culprit!

    Ali

    (@alijafarian)

    @tristanfaganguimond I actually moved on to a different Stripe plugin due to frustration.

    In the event that you’re not dependent on Gravity Forms I would suggest WP Full Stripe:
    https://codecanyon.net/item/wp-full-stripe/5266365

    I installed and configured within minutes.

    Cheers,
    Ali

    Hi Ali,

    Thanks for the update. Unfortunately, I am also using the Gravity+ Connect add-on to allow payments to be routed to users Stripe accounts, take commissions, etc. I have actually gone and deactivated all plugins except for the couple of gravity forms ones and am still having the issue.

    My next step is to deactivate the theme and try the default one, but that’s gonna take a while!

    Thanks,
    Tristan

    Ali

    (@alijafarian)

    Yep, I tried that route as well… to no avail. My code/theme was super clean (fresh TwentySixteen) so I’m pretty sure this is a bug. But instead of nagging the developer I just moved on.

    I’m surprised so few people have reported this, as it’s clearly an issue.

    Either way – good luck!

    Thanks, I have raised the issue with the plugin developer and will update the thread when I hear back.

    Taco Loco

    (@weavebranding)

    New install of the Pro version and I am getting this issue as well. I will contact support. Anyone found another work around or solution?

    • This reply was modified 2 years, 9 months ago by Taco Loco.
Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘First submission does not get token, form fails. Second submission works’ is closed to new replies.