• Resolved ChrisBAshton

    (@chrisbashton)


    Hello,

    I’ve been using MetaSlider on a client side effectively for a few weeks now. We have a number of different sliders, all working fine except the first one, which for some reason never loads the JavaScript (network tab shows no jquery.flexslider.min.js file).

    It turns out the first slideshow has “Print CSS” and “Print JS” disabled (which I know we need enabled according to this), as well as “Arrows”. I didn’t disable these, and I doubt my client did, but I suppose it’s possible.

    When I try to check these boxes, I click “Save”, it says “Saving” then “Slideshow saved”. I see a POST request to /wp-json/metaslider/v1/slideshow/save and I see the checkbox values in the request arguments, all seems good, and the response code is 200. ({“success”:true,”data”:90})

    But when I refresh the page, the checkboxes are unchecked again. The admin settings just aren’t saving. But they save fine for the other sliders!

    I’ve tried updating this plugin and the pro add-on to the latest versions, and updating WordPress itself to the latest version, but still facing this problem.

    ———————
    The issue can be found here: N/A
    The preview works: No (I see the image and caption, but no arrows or styles)
    It works with other themes: Haven’t Tried
    It works when I disable all other plugins: Haven’t Tried
    Meta Slider version: 3.14.0, then 3.15.3
    Meta Slider Pro Add-On Pack Version 2.14.0, then 2.15.2
    WordPress version: 5.3.2
    ———————

    • This topic was modified 10 months, 1 week ago by ChrisBAshton.
Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Contributor kbatdorf

    (@kbat82)

    Hi @chrisbashton

    I’ll have a fix for this in the next release (likely early January), but for now you will need to ask your hosting company to increase the max_input_vars in your php.ini file to a higher value like 9999 (default is 1000). Let me know if that works.

    That’s great news, thanks for the fast response.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘First slideshow in list is not saving’ is closed to new replies.