Support » Plugin: URL Coupons for WooCommerce » First session URL Coupon isn’t applied

  • Resolved wiebe1996

    (@wiebe1996)


    Dear Sir/Madam,

    I month ago you helped me great with my first coupon code for auto apply, now I have added a second one. When I first visit the link: http://www.natusport.nl/winkel/?coupon=adelaar10 the cooupon isn’t applied. In a second visit the coupon applies right. Is there something I could do to change this?

    Gr, Wiebe

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Algoritmika Ltd

    (@algoritmika)

    Hi @wiebe1996,

    Hmm… That’s odd… There is “Hook priority” option in the “WooCommerce > Settings > URL Coupons > Advanced”. Could you please try setting it to 1? Does it make any difference?

    Thread Starter wiebe1996

    (@wiebe1996)

    Dear Algoritmika,

    Thanks a lot for your quick response. I tried this but that doesn’t make sense. Do you have any other ideas? Could it be something with catching? But the strange part is that an other Coupon does the job right.

    Gr, Wiebe

    Plugin Author Algoritmika Ltd

    (@algoritmika)

    @wiebe1996,

    Hmm… Could you please let me know what are the differences for those two coupons (if any)? For example, maybe one is “Fixed cart discount” and another is “Fixed product discount”? Or maybe one has “Allowed emails” option set and another does not have it set? Maybe we’ll be able to figure out what’s happening then…

    Hi I have the same problem if going to https://www.gunnar.mx/?influencer=imdulcevargas adding to cart and then going to checkout or view cart nothing happends, if I close the browser and enter again with the same url then when going to view cart or finish coupon is succesfully aplied, I have enabled the hook to 1 but nothing can you help?

    Regards

    Never mind checked the option of force session start and it works beautiful

    Thank you!

    Plugin Author Algoritmika Ltd

    (@algoritmika)

    Hi @screege,

    Thanks for the update, and glad to hear you’ve figured it out.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘First session URL Coupon isn’t applied’ is closed to new replies.