Support » Plugin: WP Super Cache » First page not cached

Viewing 15 replies - 1 through 15 (of 29 total)
  • There’s a couple threads on this already…several of us on here are having the same issue πŸ™ everything but the homepage/index is being cached…index gets deleted seemingly at random.

    Hello Friends,

    I noticed that the main page is not been cache. Is there a way to cache it too?

    Thanks!

    Dear Sirs,

    I put the main page (/) at the field “Directly Cached Files” at Advanced panel, and looks itΒ΄s working.

    Is this right?

    Thanks and Regards!

    Hi Tony, Thanks! I will have to try that – wish the developer of Supercache would let us know if he’s working on this bug though.

    I’ve moved some of my blogs to W3TC because that plugin will still cache the homepage.

    wish the developer of Supercache would let us know if he’s working on this bug though

    I agree, I would also like to know if the issue is being addressed. The method described by Tony Franco might be a good temporary workaround, but for the time being I’m back to 1.4.4 which caches the frontpage just fine.

    Same problem here. But as suggested in anothee post, turning off the option “Cache rebuild. Serve a supercache file to anonymous users while a new file is being generated” seems to fix the problem.

    Hello Laurent!

    Yes, it works!

    Thanks

    Tony

    Thanks Laurent! I’m testing that out and it seems to be working so far, any downfalls to having that option unchecked?

    The cache rebuild function does have sense, see the question “What does the Cache Rebuild feature do?” in the FAQ. If I understand correctly, disabling may cause an increase of serverload on sites with lots of visitors.

    Disabling may solve the frontpage from not caching, but I still think this is a bug which should be fixed.

    My undertsanding of this option is that it changes the behavior of the cache if a user access a given page while this page is being cached or something like that. So indeed, it should have an impact only for site with loads of visitors. This is not my case so I’m not too worried about that.
    But you’re right Tommy78, this definitively looks like a bug that should be fixed. My suggestion is just a work around for the time being.

    You’re right Tommy and I hope this bug will be fixed in the next release.

    It looks like it’s related to xmlrpc.php hits. There are constant spam attacks hitting xmlrpc.php, and it looks like each one causes wp-super-cache to clear cache files if “Cache Rebuild” is checked:

    21:21:37 7816 /xmlrpc.php wp_cache_ob_callback clearing rebuilt files in /home/www-nxhm/blog/wp-content/cache/supercache/blogdomain.com/

    More Details:

    21:21:37 7816 /xmlrpc.php wp_cache_get_cookies_values: return:
    21:21:37 7816 /xmlrpc.php In WP Cache Phase 2
    21:21:37 7816 /xmlrpc.php Setting up WordPress actions
    21:21:37 7816 /xmlrpc.php Created output buffer
    21:21:37 7816 /xmlrpc.php wp_cache_get_cookies_values: return:
    21:21:37 7816 /xmlrpc.php supercache dir: /home/www-nxhm/blog/wp-content/cache/supercache/blogdomain.com/
    21:21:37 7816 /xmlrpc.php Not caching POST request.
    21:21:37 7816 /xmlrpc.php wp_cache_ob_callback clearing rebuilt files in /home/www-nxhm/blog/wp-content/cache/supercache/blogdomain.com/
    21:21:37 7816 /xmlrpc.php wp_cache_maybe_dynamic: returned $buffer

    Just noticed v1.4.6 was released. Anybody knows if this issues has been resolved in this update?

    Hello @tommy78!

    Looks like came back to work! πŸ™‚

    Thanks Support Plugin!

    Regards,

    Tony

    Tommy78, I just tested it and it still doesn’t work πŸ™ so the bug is still there.

Viewing 15 replies - 1 through 15 (of 29 total)
  • The topic ‘First page not cached’ is closed to new replies.