Support » Theme: DocPress » First my child theme of your theme worked, but now, it is broken

  • Resolved Davallen

    (@davallen)


    Hi, I really liked this theme but needed to customize it a bit to my likings.

    I first created a child theme of docpress without any issues. After I have been working on it a bit, the child theme disappeared from the Appearence -> Themes page stating an incomplete installation because of ” Template is missing.”.
    Saw in some support threads that I needed to copy the index.php file. Did that, and can now see the child theme. After activation, I get this error

    Fatal error: Uncaught Error: Class ‘wp_bootstrap_navwalker’ not found in /srv/users/serverpilot/apps/tast1/public/wp-content/themes/docpresschild/header.php:31 Stack trace: #0 /srv/users/serverpilot/apps/tast1/public/wp-includes/template.php(562): require_once() #1 /srv/users/serverpilot/apps/tast1/public/wp-includes/template.php(521): load_template(‘/srv/users/serv…’, true) #2 /srv/users/serverpilot/apps/tast1/public/wp-includes/general-template.php(45): locate_template(Array, true) #3 /srv/users/serverpilot/apps/tast1/public/wp-content/themes/docpresschild/index.php(1): get_header() #4 /srv/users/serverpilot/apps/tast1/public/wp-includes/template-loader.php(89): include(‘/srv/users/serv…’) #5 /srv/users/serverpilot/apps/tast1/public/wp-blog-header.php(16): require_once(‘/srv/users/serv…’) #6 /srv/users/serverpilot/apps/tast1/public/index.php(17): require(‘/srv/users/serv…’) #7 {main} thrown in /srv/users/serverpilot/apps/tast1/public/wp-content/themes/docpresschild/header.php on line 31

    Can you please help me with this issue?

    P.S. I’m running on php7 if that could be the issue, but have been worikng on it for at least 5-7 days without any problems.

    Best regards
    Umut รœcler

Viewing 7 replies - 1 through 7 (of 7 total)
  • Turned out, I was missing “Template: docpress” in the style.css file ๐Ÿ˜€

    Theme Author Hardeep Asrani

    (@hardeepasrani)

    Hi,

    I’m glad to know you were able to find the solution out. Have a great day. ๐Ÿ™‚

    Regards,
    Hardeep

    Hi,

    Yeah, but I’ve somehow messed the search function. It works bu no matter which live search plugin I install, it is not working.

    Have no idea what has happened ๐Ÿ™‚

    Theme Author Hardeep Asrani

    (@hardeepasrani)

    Hi,

    What do you mean by that? Could you give me more information about it? ๐Ÿ™‚

    Regards,
    Hardeep

    I’ve probably messed it up myself. I made an exact copy of your header for my child theme and have been tweaking. I can search for posts and everything works fine, but if I try to install any search related plugin, they’re not working. If I activate the parent docpress theme, it works.

    I copied the header.php and only tweaked html and have made a funtionc.php file and only added stuff so your functions file should be intact.

    You can see the website here http://46.101.141.175/ and here’s the header.php file.

    <!DOCTYPE html>
    <html <?php language_attributes(); ?>>
    <head>
    <meta charset="<?php bloginfo( 'charset' ); ?>">
    <meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1">
    <link rel="profile" href="http://gmpg.org/xfn/11">
    <link rel="pingback" href="<?php bloginfo( 'pingback_url' ); ?>">
    <?php wp_head(); ?>
    </head>
    <body <?php body_class(); ?>>
    
    	<nav class="navbar navbar-default navbar-fixedfixed-top">
    		<div class="container">
    			<div class="navbar-header page-scroll">
    				<button type="button" class="navbar-toggle" data-toggle="collapse" data-target="#docpress-navbar-collapse">
    					<span class="sr-only"><?php _e( 'Toggle navigation', 'docpress' ) ?></span>
    					<span class="icon-bar"></span>
    					<span class="icon-bar"></span>
    					<span class="icon-bar"></span>
    				</button>
    			</div>
    
    			<div class="collapse navbar-collapse" id="docpress-navbar-collapse">
    			<?php
    				wp_nav_menu( array(
    					'menu'			  => 'main_menu',
    					'theme_location'	=> 'main_menu',
    					'menu_class'		=> 'nav navbar-nav navbar-right',
    					'fallback_cb'	   => 'wp_bootstrap_navwalker::fallback',
    					'walker'			=> new wp_bootstrap_navwalker())
    				);
    			?>
    			</div>
    		</div>
    	</nav>
    
    	<header class="jumbotron">
    		<div class="container text-center">
                <a href="http://46.101.141.175">
                   <div id="logo">
                        <p id="logotekst">tast</p>
                        <div id="logoikon">
                            <div id="logotal" class="fadeImg">
                               <img src="/wp-content/themes/docpresschild/assets/img/Logogif.gif" alt="tast1 gif">
                            </div>    
    
                            <img id="logoikonikon" src="/wp-content/themes/docpresschild/assets/img/logoikon.png" alt="logoikon" >
                            <span id="alpha">ALPHA</span>
                        </div>             
    
                    </div>
                </a>
    
    		<?php
    			$docpress_header_title = get_theme_mod('docpress_header_title',__( 'Need Help? Try me!', 'docpress' ));
    			$docpress_header_subtitle = get_theme_mod('docpress_header_subtitle',__( 'Your answer is just one search away!', 'docpress' ));
    			$docpress_header_search_display = get_theme_mod('docpress_header_search_display');
    		?>
    		<?php if(!empty($docpress_header_title)) : ?>
    			<h2><?php echo $docpress_header_title; ?></h2>
    		<?php else: ?>
    			<h2><?php bloginfo( 'description' ); ?></h2>
    		<?php endif; ?>
    		<?php if(!empty($docpress_header_subtitle)) : ?>
    			<h3><?php echo $docpress_header_subtitle; ?></h3>
    		<?php endif; ?>
    		<?php if( isset($docpress_header_search_display) && $docpress_header_search_display != 1 ): ?>
            <form role="search" method="get" id="searchform" action="<?php echo home_url( '/' ); ?>">
                <input type="text" value="" name="s" id="search-form" placeholder="Sรธg efter virksomhed" autofocus="autofocus" />
            </form>
    
    		<?php endif; ?>
    		</div>
    	</header>

    Damn lol, turns out to be a z-index issue so it was simply covered behind .jumbotron div with header image ๐Ÿ˜€

    Theme Author Hardeep Asrani

    (@hardeepasrani)

    And you again figured it out by yourself. Don’t forget to leave a review if you like the theme. ๐Ÿ™‚

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘First my child theme of your theme worked, but now, it is broken’ is closed to new replies.