Support » Plugin: Events Manager » First mouse scroll over map triggers zoom

  • Resolved noapi1

    (@noapi1)


    Hi,

    great plugin!

    One issue: When opening an event-post with a map and scrolling down the page with mouse wheel, page-scrolling ends and instead the map is zooming out, if cursor enters map. If I first scroll to the map and stop, before cursor reaches the map, then I move the cursor over the map (without mousewheel) and out of the map again, now I can scroll over the map without zooming in both directions.

    So there seems to be an issue with initialization of map/zoom-disabling. Any idea how to fix this?

    Another issue: Although I deactivated comments on places-posts the comment form is displayed. Deactivation on event-posts works correctly.

    Thanks!

Viewing 6 replies - 16 through 21 (of 21 total)
  • Plugin Support caimin_nwl

    (@caimin_nwl)

    NetWebLogic Support

    No, but there is code to prevent scrolling unless the user has clicked the map.

    I don’t understand, why I need additional code if there is set the wrong flag as default?

    But if you want to keep this: Which code do I need and where should I put it in? Is there any example?

    To always change the flag after every update does not really make any sense.

    Plugin Author Marcus

    (@netweblogic)

    NetWebLogic Support

    I can reproduce the issue you described, but only on certain browsers.

    On chrome it seems to be working fine. The behaviour is that users should be clicking first on the map and then being able to scroll.

    There’s code we added in there that’s specifically doing that (google doesn’t have that behaviour), I’ve logged this as a bug and will check it out asap.

    Great, thanks.

    Plugin Author Marcus

    (@netweblogic)

    NetWebLogic Support

    hey, just following up that this should have been fixed in the update 5.8.1.1

    let us know if not

    fyi, there’s a related bug that is an issue with Google Maps, not us, which I’ve reported to them: https://issuetracker.google.com/issues/71954545

    Works all fine now, thank you!

Viewing 6 replies - 16 through 21 (of 21 total)
  • You must be logged in to reply to this topic.