Support » Plugin: WooCommerce Services » First class mail not showing

  • So i am shipping an item that weighs 1oz, however, during checkout, the option for first class mail is missing, it only shows priority mail and priority mail express. I never had this problem before when using woocommerce usps shipping plugin.

Viewing 15 replies - 1 through 15 (of 42 total)
  • What do you have chosen for Parcel Packing Method? I ran into this last week and then switched to Weight Based. First Class then appeared.

    I’m having this same problem. Where is the Parcel Packing Method setting?

    Hi dvlwearsparsley, so if you have the latest Woo USPS plugin and you have your zones setup you need to go into zones, then U.S. then USPS and scroll down. You’ll see the label Parcel Packing Method. Play around with this setting and see what happens.

    `

    • This reply was modified 2 years, 8 months ago by stefsterNYC.

    I too am having issues with the USPS shipping methods. Suddenly First Class, which was working as expected until last week, stopped showing up as an option even for items weighing less than a pound. Checking the settings for USPS under the shipping zone I set up, the “recommended pack into boxes with weight and dimensions” was set but 1st class did show as an option in the cart. Changing the setting to “weight based: regular sized items are grouped…” gets the first class option back for items that fall in that weight range. However, now I can’t change the amount added to the First Class parcel option to cover the cost of the box and packing material. Where First Class had been showing $4.67 for most orders, now it shows $3.00. Nothing I do in the settings changes the cost of First Class. I do want to offer this as an option, but not if it won’t cover my cost.

    Kcellis, I’m having that same issue too. I haven’t figured it out yet. Woo was able to get it to work on their test site when I was working with them the other day. % worked once for me but then stopped. This is really strange. I think there’s enough people here to really have Woo look at it again.

    • This reply was modified 2 years, 8 months ago by stefsterNYC.

    I have submitted a ticket to WooCommerce and I also noticed that the First Class not showing as an option in the cart began the same time I set up ShipStation integration with WooCommerce. ShipStation still uses Stamps.com (which I had been using) to print postage. Disabling the ShipStation plugin did not resolve the issue.

    @kcellis, I also put a ticket in and they were unable to replicate while we both worked on it. I disabled all shipping plugins, ie Ship Easy and everything else and only enabled USPS and Woocommerce and it still didn’t change. I even went to use a default WP theme. No change. So I’m not sure what’s going on there.

    Thanks for your reply, @stefsternyc! I feel like I’m in the right place here, but your screenshot doesn’t look like my screen at all – I don’t have the weight based option. I’m using WooCommerce Services, version 1.7.0, and latest WordPress version 4.8.1 – both current as of 9/11/2017. First, am I in the right place (WooCommerce Services plugin), and second – is there perhaps another plugin that enables these features? Here’s what my screen looks like for “Shipping Zones –> USA –> USPS (WooCommerce Services)” What am I doing wrong? Thanks in advance

    @dvlwearsparsley, you’re in the right place. I may be in the wrong place but it’s similar across the board. Meaning that both SERVICES and USPS use the same API to call for rates. However, you may not see the same screen as someone not using SERVICES. We’re all experiencing a loss of First Class not showing and not being able to add additional fees for the likes of labor, boxes, fill, etc.

    We’re hoping Woo can figure this out but having worked with them for years we have a better chance of winning the lottery beforehand.

    Gotcha – I want to be able to use the weight based feature though, so will check out that USPS plugin. Thanks again @stefsternyc! I’ll be praying for the lottery… LOL

    The Service plugin is stored on Automattic’s servers rather than on your own. So it puts less of a load on your own servers. Making your site load faster. So it’s keen in that sense. However, I’ve never used it but have read its documentation.

    • This reply was modified 2 years, 8 months ago by stefsterNYC.

    Hey gang, I’m not sure if anyone else has heard this but there is a problem with USPS sending First Class rates. I just spoke to Woo and they’re working on a patch. Seems USPS created new First Class rates and that’s why they’re not showing. So we’re waiting for a patch.

    The new rate is First-Class Package Service – Retail (TM), but it does not show up in the plugin yet. The new one is in addition to the First-Class package Service already listed in the First-Class options.

    I mean all First Class rates all together. If you put your shipping options on DEBUG you’ll see which ones are coming thru the API and which ones aren’t. I only get two. Postcards and Large Envelopes. I’m using Large Envelopes and adding additional costs to that field to cover my expenses. However that calculation isn’t matching one bit but at least it’s better than $3.00.

    I also switched my Parcel Packing Method from Weight to Default to get that. Otherwise nothing worked.

    WooCommerce is working on USPS shipping plugin update that includes the new First-Class Package Service – RetailĀ® which is in addition to their First-Class Package Service apparently. The plugin update does allow adding an additional charge to that First-Class shipping option, but I was not able to get the 1st option to show in the cart unless I choose weight based.

Viewing 15 replies - 1 through 15 (of 42 total)
  • The topic ‘First class mail not showing’ is closed to new replies.