WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] First argument is expected to be a valid callback, 'new_excerpt_more'

[Resolved] First argument is expected to be a valid callback, 'new_excerpt_more'

  • Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, ‘new_excerpt_more’ was given in /home/amw188/public_html/wp-includes/plugin.php on line 170.

    I get this error above each blog post in two cases. When I use <?php the_excerpt() in page templates and when I click on a category list widget item.
    How do I make this disappear?

    my website

    Background info:

    I’m using the whiteboard theme and 0 plugins. I’ve made significant changes to the theme php files and haven’t touched functions.php.

    I’ve used the same theme files and wp version on plesk servers without having this issue but I am using a host gator server now and am having this issue. I am using php 5 on host gator.

Viewing 1 replies (of 1 total)
  • Fixed it but I have a new concern for whenever I want to replace the [….] from excerpts in the future.

    In functions.php I had to remove these lines:

    add_filter('excerpt_more', 'new_excerpt_more');
    	// custom excerpt ellipses for 2.9+
    	function custom_excerpt_more($more) {
    		return 'Read More &raquo;';
    	}
    
    	add_filter('excerpt_more', 'custom_excerpt_more');
    	// no more jumping for read more link
    	function no_more_jumping($post) {
    		return '<a href="'.get_permalink($post->ID).'" class="read-more">'.'&nbsp; Continue Reading &raquo;'.'</a>';
    	}
    	add_filter('excerpt_more', 'no_more_jumping');
Viewing 1 replies (of 1 total)
  • The topic ‘[Resolved] First argument is expected to be a valid callback, 'new_excerpt_more'’ is closed to new replies.
Skip to toolbar