WordPress.org

Support

Support » Plugins and Hacks » Jetpack by WordPress.com » [Resolved] firms don't display properly

[Resolved] firms don't display properly

Viewing 15 replies - 1 through 15 (of 20 total)
  • Bryan Villarin

    @btvillarin

    Happiness Engineer at Automattic

    Hi,

    Can you reply with the URL to the form so we can take a look?

    What version of Jetpack are you using? Can you upgrade to the latest version (2.0.4) and let me know if that helps?

    Yep, got the same thing… and noticed that it is happening on a Multisite setup on all sites except the main site. The main site has the grunion stylesheet included with the contact form as usual (I suppose) but on all other sites the stylesheet is missing.

    JetPack 2.0.4 on WordPress 3.5 multi-site.

    I’m using the Twenty Twelve theme with the Jetpack form, and it’s hosed.

    Contact

    Yep, that one is missing the Grunion stylesheet too… Does switching to another theme change anything?

    A work-around (for now) can be to paste this code just above the form shortcode right inside the page:

    <link rel='stylesheet' id='grunion.css-css' href='/wp-content/plugins/jetpack/modules/contact-form/css/grunion.css?ver=2.0.4' type='text/css' media='all' />

    Thanks Ravan. That at least has it looking ok for now, and no changing the theme didn’t change anything.

    UPDATE: I think I found the culprit…

    Try disabling the Shortcode Embeds module in the Jetpack settings. In my case it restored (without that stylesheet addition to page content) the old contact form look.

    Can anyone confirm this?

    ^ worked like a charm so far!

    UPDATE 2: I have a site where Shortcode Embeds is enabled but Publicize and Sharing are disabled. The contact form displays correctly. But as soon as I activate Publicize or Sharing, the form breaks…

    Very weird and elusive issue.

    mine is fine I have everything else on but shortcodes

    i also hat to disable the shortcuts module.

    Yet again the forms part of JetPack has stopped working, and just displays the code without creating a form.
    This is pretty crucial stuff if you need enquiries to earn a living and it has happened at least twice in the last 3 months.
    I don’t have any of the listed clashing plug ins, and it was working fine until the recent upgrades.
    I have had to remove it and rely on mailto..

    Help!
    (and not to be grouch – JetPack is great but I wonder if it would be possible to removed files associated with features which we don’t use – Hostgator penalises extra files and I am forever having to remove other plugs ins to avoid going over the limit (but lots of sites, so most wouldn’t find it a problem!)

    i insert the css grunion. it solved the problem, but i cant see how to remove embed shortcodes.
    i have a multisite with twenty twelve.

    i guess i´ll have to stick with that

    @stevepett, was this after a recent update? I’ve never seen that happen… anyway, your issue seems unrelated to the OP’s issue with the contact form missing it’s usual styling. Could you create a new thread?

    Plugin Contributor Christopher Finke

    @cfinke

    Design Engineer at Automattic

    This problem (which was a conflict between the Contact Form and the VideoPress shortcode) has been fixed for Jetpack 2.1 (http://plugins.trac.wordpress.org/changeset/647091)

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘[Resolved] firms don't display properly’ is closed to new replies.
Skip to toolbar