Support » Plugin: Wordfence Security - Firewall & Malware Scan » Firewall wont turn on

  • Hello i am running the latest version of wordpress and wordfence. As it has changed a little since the new facelift i cannot find where to block custom names that may try to log into admin. From what i can see its part of the firewall settings. However my firewall is turned off and when i choose ‘enabled and protecting’ from the firewall options page i cannot click the ‘save changes’ button. I have tried it on multiple computers and it is the same. Do you know what i am doing wrong or have any suggestions? It has been like this for a few weeks but as the recent wordfence upgrade came out recently i was hoping that may rectify it, but it has not.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Hi @graemeallan,

    In Wordfence 7 you can find Blocked IPs in the section Firewall > Blocking.

    If you prefer to have a link to Blocking in the left navigation as it used to be in earlier versions of Wordfence:
    1. On the “Blocking” page click “Blocking Options”
    2. In the “General” section of this page select “Display top level Blocking menu option”
    3. Hit “Save Changes”

    This can also be done from the “Wordfence –> Dashboard –> Global Options” page:
    1. Go to the “View Customization” section
    2. Tick the “Display “Blocking” menu item” checkbox
    3. Hit “Save Changes”

    The fact that you can’t click the “Save Changes” button could be caused by a conflict with one of the plugins installed or the theme you’re using.

    Could you please try switching to a default theme or disabling all other plugins and reactivating them one by one to see if the issue is indeed related to a conflict?

    To do so I recommend the “Health Check” plugin which allows you to disable all plugins and switch to a default theme, but only for your user.

    Thanks for your help. I actually ended up doing the wordfence diagnostic and it said there was the WAF and config folders that were not writable. They were already set to 744 but i had to change them to 774 for it to work. Is this ok / safe on 774?

    Hi @graemeallan,

    Can you confirm the owner/group of the “wflogs” folder is the user the web server runs as?

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Firewall wont turn on’ is closed to new replies.