Support » Plugin: Wordfence Security - Firewall & Malware Scan » Firewall status is idle, despite manually changing php.ini

  • Resolved nicha16

    (@nicha16)


    I’m using the latest version of WordPress and Wordfence. The host is at SiteGround.

    This is my first installation of Wordfence. The normal config doesn’t work as I’m hosted at Siteground, so went ahead with the manual config. The php.ini was modified correctly according to SiteGround tech support (despite needing their tech support to change it manually as the suggested method by Wordfence returns an error.)

    I’ve waited for 1 hour and still no change in status, and the config screen doesn’t changes.

    Can you advice how to deal with this?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Hi @nicha16,

    In order to make sure the “auto_prepend_file” was properly set:

    • Go to the Wordfence Tools page
    • Click the Diagnostics tab
    • In the Other Tests section (near the bottom of the page), click the link that reads “Click to view your system’s configuration in a new window“. This will open a Wordfence System Info page

    Check the values (local and master) associated with the “auto_prepend_file” parameter.

    Also please confirm that the php.ini file your hosting provider edited is the one appearing as the “Loaded Configuration File” on the Wordfence System Info page.

    Thread Starter nicha16

    (@nicha16)

    The auto_prepend_file returns “no value” for both local and master value.

    How should I handle this?

    Also, where can I find teh Wordfence System Info page? I’m new to Wordfence. Thank you so much.

    Hi @nicha16,

    The Wordfence System Info page is where you saw the local and master values for the “auto_prepend_file” directive.

    If it says “no value” there, then the parameter is simply no set. I suggest you try and set the “auto_prepend_file” directive in the PHP Variables Manager via your site’s cPanel as outlined in our documentation.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Firewall status is idle, despite manually changing php.ini’ is closed to new replies.