Support » Plugin: Wordfence Security - Firewall & Malware Scan » Firewall optimization site crashed – URGENT!

  • Resolved thebigbang

    (@thebigbang)


    Hi,
    I’m using Wordfence in free version. I’ve configured the Firewall but there is always this advice: “To make your site as secure as possible, take a moment to optimize the Wordfence Web Application Firewall”.

    You wrote me that: “As your site is hosted at SiteGround please follow these instructions here:
    https://www.wordfence.com/help/firewall/optimizing-the-firewall/#on-siteground-and-other-similar-hosts-that-use-cpanel”.

    I followed the instruction but the site crashed. I contacted the assistance of SiteGround and they tried to do the same procedure and they said me that:
    – when they insert the path: /home/public_html/wordfence-waf.php the site shows errors.
    – Instead inserting only: wordfence-waf.php the site doesn’t present problems.

    What can I do?
    You closed my previous tickets so I have to open an other one.
    Thanks again in advance.
    Regards

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Support WFGerroald

    (@wfgerald)

    Hey @thebigbang,

    What error do you receive when the site crashes? Are you able to share the PHP error logs?

    Can you please share the contents of your wordfence-waf.php file?

    Thanks,

    Gerroald

    thebigbang

    (@thebigbang)

    Hi,
    the assistance of SiteGround made the procedure for me so I only know what they wrote me, so that:
    – when they insert the path: /home/public_html/wordfence-waf.php the site shows errors.
    – Instead inserting only: wordfence-waf.php the site doesn’t present problems.
    I can ask to the SiteGround assistance to send me the php error log and
    I can look for the contents of my wordfence-waf.php file. Do you want I copy and paste them here in a message?
    Thanks in advance.

    Plugin Support WFGerroald

    (@wfgerald)

    Hey @thebigbang,

    It’s fine to paste it here if you’d like. However, if you prefer to share it privately you can email me at wftest.wordfence.com. If you do email it, please include your WordPress.org username, and link to this thread, and update this thread in case it’s missed.

    Thanks,

    Gerroald

    • This reply was modified 3 months ago by WFGerroald.
    thebigbang

    (@thebigbang)

    Hi,
    I contacted again the SiteGround assistance and they said me that they controlled the Error log and that there aren’t errors.
    I downloaded the wordfence-waf.php file but I can’t send it to you because there should be an error in your email. Can you please write it again?
    Thanks in advance.
    Best regards

    Plugin Author WFSupport

    (@wfsupport)

    The email is wftest [at] wordfence [dot] com.

    Tim

    Plugin Support WFGerroald

    (@wfgerald)

    Hey @thebigbang,

    As Tim mentioned, the actual email is wftest@wordfence.com. I had a typo and missed the @ character. Please do update this thread once it’s sent in case we miss the email.

    Please let us know once you’ve sent it.

    Thanks,

    Gerroald

    Hi Gerroald,
    I sent you an email with the wordfence-waf.php file on the 24 October. Have you received it?
    Looking forward you.
    Kind regards

    Plugin Support WFGerroald

    (@wfgerald)

    Hey @thebigbang,

    Thanks for sending the file over. I’ve updated you via the email. Please update this thread once you’ve responded in case the email is missed.

    Thanks,

    Gerroald

    Hi Gerroald,
    I’ve sent you the email with whom you asked.
    Regards

    Plugin Support WFGerroald

    (@wfgerald)

    Hey @thebigbang,

    From the screenshots, it looks like it isn’t getting the full/correct path.

    Can you please try to set it up again, and also share the auto_prepend_file path Wordfence shows?

    Go to your cPanel and go to PHP Variables Manager. Click the subfolder that your current WordPress site is located in there. If it is in public_html, click that. You will then see a field where you can enter a variable. Enter: auto_prepend_file there and click add. You will see a new field come up for auto_prepend_file where you can enter a path. We will return here in a second.

    In a new tab, go back to your site and goto Wordfence > Firewall > All Firewall Options. Click the Optimize the Wordfence Firewall and then click the dropdown box and select Manual Configuration at the bottom, then continue. You will then see something similar to this:

    auto_prepend_file = '/home/sitename/public_html/subfolder/wordfence-waf.php'

    Just copy the path inside the ‘ ‘ symbols, in this case, /home/sitename/public_html/subfolder/wordfence-waf.php
    Go back to your PHP Variables Managers tab and paste that path (/home/sitename/public_html/subfolder/wordfence-waf.php) into the auto_prepend_file field and click the checkbox for Apply changes to all subdirectories? and click Save.

    Make sure the confirmation screen has no errors, then go back to your site and refresh it.

    Please give this a try and let me know how it goes. If it doesn’t work this time, please share the given path.

    Thanks,

    Gerroald

    Plugin Support WFGerroald

    (@wfgerald)

    Hey @thebigbang,

    We haven’t heard back from you in a while, so I’ve gone ahead and marked this thread as resolved.

    Please feel free to open another thread if you’re still having issues with Wordfence.

    Thanks,

    Gerroald

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.