Support » Plugin: Wordfence Security - Firewall & Malware Scan » firewall configuration

  • Resolved dean34

    (@dean34)


    Hello,
    the firewall cannot be configured, when i click on (optimize the wordfence firewall) the screen popup with the continue button at the bottom of the screen is unclickable, wherever i change in the options the firewall always shows me red color 35%.

    in advanced firewall option > rules . here all list are sat disabled and can’t be changed.
    i want to send you screenshots but no options here sorry

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Support WFAdam

    (@wfadam)

    Hello @dean34 and thanks for reaching out to us!

    On some sites, depending on the host, you need to set up the firewall manually. I can walk you through that process with a diagnostic.

    Can you send a diagnostic report to wftest @ wordfence . com? You can find the link to do so at the top of the Wordfence Tools > Diagnostics page. Then click on “Send Report by Email”. Please add your forum username where indicated and respond here after you have sent it.

    Thanks!

    Thread Starter dean34

    (@dean34)

    Hi ,
    Done, the report has been sent

    thank you

    Plugin Support WFAdam

    (@wfadam)

    Thanks for sending that diagnostic!

    It looks like the firewall is configured properly. Try to disable Wordfence and then enable it again. Let me know if this corrects the percentage. It won’t be 100% since it’s the free version.

    Let me know if this helps!

    Thanks!

    Thread Starter dean34

    (@dean34)

    disable? do you mean deactivate the plugin and activate it again?

    Plugin Support WFAdam

    (@wfadam)

    Yes. This should force the tables to reload.

    Let me know what you get!

    Thanks!

    Thread Starter dean34

    (@dean34)

    Hi again WFAdam

    i have done that, unfortunately, no change at all, the firewall red flag 35%, and firewall rules still disabled as i mentioned earlier, why this list is disabled for me and i have no control over it? 
    
    on my other website, the firewall rules list is open just fine and i have complete control that i can allow and not allow whatever i need on this list.
    
    but here i can't change anything in this list, as i said its unclickable i can't enable or disable anything, and this caused me a problem,  i want to make sure that rank math is whitelisted. Here's the recommendation i got from rank math regarding the issue I'm facing:
    
     -  If you are experiencing issues while saving your SEO Title, Description, or Focus keyword then:
    
     you can whitelist the file using or use WordFence in Learning Mode. These instructions are for WordFence but will likely work on any firewall plugin/software.
    
    How to Ensure Rank Math Meta Data Can Be Updated
    Go to WordFence > Tools. Click on Whitelist Param from Firewall.
    
    You have to ensure that the file is whitelisted and access to it isn’t blocked using a plugin like WordFence. You can install WordFence as well and see if you can replicate the issue. If you aren’t sure, then you can ask the web host why that file is showing a 403.
    • This reply was modified 2 months, 2 weeks ago by dean34.
    Plugin Support WFAdam

    (@wfadam)

    It might be a failed table then. A complete re-install of Wordfence might be a good step. It’s always best to make a backup of the site and database before installing/removing plugins, just to be safe.

    Additionally, you can backup your Wordfence settings via the Export option. Navigate to Wordfence > Tools > Import/Export Options and click Export. You can also take note of the current Whitelisted URLs you have in Wordfence > Firewall > All Firewall Options > Whitelisted URLs as these are NOT included in the Import/Export, and will be lost during the re-install.
    Here is what is exported: https://www.wordfence.com/help/tools/import-export/
    During the export, you will be given a long string of text. Keep this safe, you’ll need it in a few minutes.

    After that, enable the option to Delete Wordfence tables and data on deactivation in All Options > General Wordfence Options. You will want to remember to disable this after you reinstall Wordfence again.

    After you enable that option, you can deactivate Wordfence from the Plugins area of your site, then delete it. Next, from the plugins area, search for and re-install Wordfence like normal.

    It will be like setting Wordfence up for the first time. You will need to enter an email address, and then go into Tools > Import/Export Options and paste that string of text into the Import Wordfence Options field and click the button there.

    The firewall will be in Learning Mode by default for 7 days. I would recommend switching this to Enabled and Protected as soon as possible.

    Let me know if this works! We want to get the firewall working properly before we set up your Allowlist for Rank Math SEO.

    Thanks!

    Thread Starter dean34

    (@dean34)

    i have followed your instruction and install fresh wordfence,
    i got the same results as before, if you like to allow me to send you screenshots! it might help

    Plugin Support WFAdam

    (@wfadam)

    Sure! Send them to wftest @ wordfence . com with the subject “dean34 Screenshot” and let me know once you have sent them.

    I will keep an eye out for them.

    Thanks again!

    Thread Starter dean34

    (@dean34)

    Done, the screenshots have been sent to your email

    thank you

    Plugin Support WFAdam

    (@wfadam)

    Thanks for sending those to me!

    I did a further look into your diagnostic and noticed you’re hosted with NameCheap. Are you on a shared server by chance?

    You may need to add the php.ini file with the auto_prepend_file statement that Wordfence will give you when you use manual configuration. I recommended backing up your current htaccess file, then removing everything from the htaccess file that starts with #Wordfence WAF to the end of it, in order to start fresh for what we are about to change.

    Create a PHP.ini file in the same directory your htaccess file is located. Within the php.ini file, add this code:
    auto_prepend_file = '/path/to/waf/wordfence-waf.php'
    **MAKE SURE TO CHANGE THE FILE PATH TO POINT AT YOUR WORDFENCE-WAF.PHP FILE**

    In order to make the php.ini load you will need to add this to the .htaccess file:
    lsapi_phpini /home/user/public_html/php.ini

    https://www.namecheap.com/support/knowledgebase/article.aspx/9314/2219/how-to-edit-phpini-on-shared-servers

    https://www.namecheap.com/support/knowledgebase/article.aspx/9310/2219/lsphp-directive-for-phpini-on-shared-servers

    Once you get all of that set, navigate back over to your Wordfence > Firewall page and let me know the results.

    Hope this helps!

    Thanks again!

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.