Support » Themes and Templates » Firefox problems

  • Hi,

    is there a known but in WP 2.3 that has a problem with Firefox? No matter what theme I use my posts look fine in IE7 but are either all pushed to the left with sentences that don’t wrap within the container. Is this a CSS issue or something with one of the posts?

    http://www.joyceanddoug.com/blog

Viewing 15 replies - 1 through 15 (of 15 total)
  • I’m suddenly having the same or similar issue. I set up my blog last week, set up a theme, checked it in Firefox, and it looked fine.

    Posted a link to my list, and now only the header and footer show up, the linksrolls are pushed way down, and post backgrounds aren’t showing… but only in firefox!

    I reinstalled, thinking it might be a WP bug, but no luck.

    Moderator kmessinger

    (@kmessinger)

    It is not FF or WP. You have an error somewhere. If this started with “posted a link” then check there for a start.

    I’m having similar issues. Re-installed WP but no change. It is a WP issue. Looks ok until a picture is posted and then all hell breaks loose. Firefox can’t even handle the default and classic themes. Just as well I use IE really! Irritating though.

    Moderator kmessinger

    (@kmessinger)

    suggymoto – First correct your code so it validates at http://validator.w3.org/ Then in FF you can use the error console to show possible errors. Hopefully the problem can be solved with those actions.

    Thecodont – do the same. Your blog failed validation which means it will display with unexpected results.

    Also both of you should check to make sure any widgets you are using are compatible with WP. Often WP updates and Widget creators do not.

    I have the same problem. I updated all the code as requested in the WP update service and that didn’t fix it. I figured it was the template I was using so I went back to the kubrick theme that was provided in the download, removed widgets, validated code in the w3.org validator, upgraded firefox and I have the same problem. It works fine in IE7 and Opera but not FF or Flock.

    Any suggestions?

    I read a bit more of KMessinger’s reply and realized that I missed the console check in FF. This is the error that I’ve received.

    Error: The stylesheet http://domain.com/blog/wp-content/themes/default2/style.css was not loaded because its MIME type, “text/html”, is not “text/css”.

    Source File: http://domain.com/blog
    Line: 0

    No matter the theme, the result is the same. Thanks for the advice, I’ll continue looking into it. If you have a suggestion, please let me know.

    Best regards.

    Moderator kmessinger

    (@kmessinger)

    Thecodont – yours look fine in FF

    suggymoto – the Flash movie is causing your problem

    michaelbradley – it would be good to have a url so we could check things out

    I’ve changed it back to the proper theme. The URL is http://freewordsofchrist.org/wocm/

    Thanks!

    I’m almost convinced the condition can be cleared up with a modification of the .htaccess file or a chat with my host. Thoughts?

    I’m almost convinced the condition can be cleared up with a modification of the .htaccess file or a chat with my host. Thoughts?

    Sure, it’s worth a try. Add this to your .htaccess (first line):
    AddType text/css .css

    That’ll do it for a temporary fix. Alternatively, the host needs to modify their server configuration to set *.css to be text/css files. Them doing it is better in the long run than the .htaccess fix, but that should work if you have .htaccess enabled correctly.

    YES! That worked.

    In .htaccess, add:
    AddType text/css .css

    Hey Michael – thanks for the solution.

    Can you step me through what I need to do? I don’t know about the .htaccess file – and adding to it. Can you explain where it is, getting to it and changing it please?

    thanks

    Thanks Moshu!

    Okay – so i’ve found the .htaccess. I tried to edit it using FTP on the blog. It wouldn’t allow access. So I downloaded it and tried editing it there. It wouldn’t allow me in either.

    can you help me. the “You can edit the .htaccess file by FTP” is a bit advanced in assuming I know how to edit it.

    Yeah my problem was fixed. It is embedded Flash posts that cause the problem. I’ve now installed a plugin for adding video files and it works fine – Vipers Video Quicktags

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Firefox problems’ is closed to new replies.